Quais navegadores são suportados pelo Canvas?

Document created by Canvas Doc Team Employee on Nov 6, 2017
Version 1Show Document
  • View in full screen mode

Por ser construído utilizando padrões web, o Canvas pode funcionar no Windows, Mac, Linux, iOS, Android, ou qualquer outro dispositivo com um navegador web moderno.

Navegadores suportados

O Canvas suporta os lançamentos atuais e o primeiro lançamento principal prévio dos seguintes navegadores:

  • Internet Explorer 11 e Edge 39 and 40 (Windows apenas€”certifique-se de que seu sistema operacional também é atual conforme observado na lição de especificações do computador; talvez seja necessário baixar a Atualização Windows 10 Anniversary Update para enviar do Canvas)
  • Safari 9 e 10 (somente para Macintosh)
  • Chrome 60 e 61
  • Firefox 54 e 55 (Extended Releases não são suportados)
  • Flash 26 e 27 (usados para gravação ou visualização de áudio/vídeo e carregamento de arquivos)
  • Navegador Respondus LockDown (suportando os mais recentes requisitos do sistema)

 

Nós recomendamos fortemente que você atualize seu navegador preferido para a versão mais nova. Seu navegador irá te avisar se existir uma nova versão disponível.

Alguns navegadores suportados podem produzir um banner dizendo Seu navegador não atende os requisitos mínimos para o Canvas (Your browser does not meet the minimum requirements for Canvas). Se você atualizou seu navegador, mas ainda continua vendo essa mensagem de alerta, tente sair do Canvas e excluir os cookies de seu navegador.

Atualizações do Navegador

Se seu navegador não é atualizada automaticamente, você pode baixar o seu navegador preferido na página de download do navegador:

  • Internet Explorer e Microsoft Edge
  • Safari
  • Chrome
  • Firefox
  • Navegador Respondus Lockdown

Componentes Obrigatórios

Flash é necessário para gravar áudio e vídeo no Editor de Conteúdo Avançado do Canvas. Além desses recursos, não é exigido o uso do Flash na maioria das áreas do Canvas. Note que alguns navegadores podem não suportar mais o Flash.

O plug-in Java é obrigatório para compartilhamento de tela em Conferências (Conferences). Note que alguns navegadores não suportam Java. Caso contrário, não há nenhum outro plug-in de navegador utilizado pelo Canvas.

É necessário que o JavaScript esteja habilitado para usar o Canvas.

Plugins e Extensões de Navegador

Alguns plugins ou extensões de navegador podem entrar em conflito com o Canvas e afetar a funcionalidade. Se você vivenciar um comportamento que não permite que você veja ou participe de cursos do Canvas, verifique se você desativou todas as extensões ou plugins que interagem diretamente com o navegador da Web.

Para solucionar problemas, considere fazer logon no Canvas usando uma janela de navegador anônima ou privada, que fornecerá uma sessão do navegador sem qualquer histórico de navegação ou de pesquisa anterior, cookies do navegador associados ou outros fatores que possam interferir com o navegador. Se você for capaz de exibir e participar do Canvas usando uma janela de navegador anônima ou privada, o comportamento que está ocorrendo provavelmente está relacionado ao navegador e não ao Canvas.

Configurações de Privacidade no Navegador

Recomendamos seguir quaisquer políticas de segurança do navegador estabelecidas pela sua instituição, especialmente se você estiver usando o Canvas em um computador fornecido pela instituição.

Ao exibir conteúdo, o padrão do Canvas é a preferência definida por um navegador específico. Alguns navegadores podem ocasionalmente fazer modificações nas configurações de privacidade para proteger usuários de um possível conteúdo inseguro. Conteúdo não protegido é identificado com o prefixo http:// na URL e pode criar conteúdo misto em sua página do Canvas. Conteúdo seguro é identificado com o prefixo https:// na URL. Para obter a melhor experiência do usuário, o conteúdo deve ser seguro para evitar conflitos de navegador.

  • Se você for um administrador do Canvas, conteúdo não protegido pode ser causado ao hospedar um arquivo JC/CSS não protegido fora do Canvas. Se carregamentos personalizados forem suportados para a sua conta, é possível hospedar seu arquivo no Editor de Temas do Canvas, o que resolverá quaisquer conflitos do navegador.
  • Se você for um instrutor do Canvas que incorpora lições do Canvas dentro do seu curso, é possível evitar problemas de navegador com conteúdo misto usando URLs protegidas do Canvas Guides. 

 

Comportamentos Conhecidos dos Navegadores

Em navegadores como o Safari, o conteúdo inseguro nunca será exibido no navegador.

No entanto, no Chrome e no Firefox, você tem a opção de exibir conteúdo inseguro. Por favor, tenha atenção com as possíveis restrições e visualize conteúdos inseguros com cuidado.

Seguem-se problemas conhecidos no Chrome e no Firefox que podem bloquear ou criar conteúdo misto no Canvas.

Segurança no Chrome

Segurança no Chrome

O Google Chrome verifica se o conteúdo do website que você está visualizando é transmitido de forma segura. Se você visitar uma página em seu curso no Canvas que é conectada a um conteúdo inseguro, o Chrome irá exibir um bloqueio com um ícone de aviso [1] na barra de endereços do navegador.

Você pode escolher por ignorar a restrição de segurança e exibir o conteúdo de qualquer maneira clicando no bloqueio com um ícone de aviso e depois clicando no botão Carregar script inseguro (Load unsafe script) [2].

Permissões de mídia no Chrome

  Permissões de mídia no Chrome 

O Chorme tem suas próprias permissões de mídia com o navegador. Para usar a câmera e microfone do seu computador com qualquer funcionalidade do Canvas, você terá que aprovar duas permissões:

  1. Permitir acesso para o Canvas através das Configurações do Adobe Flash Player [1]. Essa janela (prompt) irá aparecer no centro de janelas de áudio e vídeo, ou no centro do navegador se você estiver acessando Conversações (Conversations).
  2. Permitir acesso ao Canvas através das configurações de permissões de mídia do Chrome [2]. Essa janela (prompt) irá aparecer bem abaixo da barra de endereços. Clique no botão Permitir (Allow).

Segurança no Firefox

Segurança no Firefox

O Firefox verifica se o conteúdo do website que você está visualizando é transmitido de forma segura. Se você visitar uma página em seu curso no Canvas que é conectada a um conteúdo inseguro, o Firefox irá exibir um  de  [1] na barra de endereços do navegador.

Você pode escolher por ignorar a restrição de segurança e exibir o conteúdo de qualquer maneira clicando no bloqueio do ícone de aviso, clicando na seta para expandir suas opções [2], e clicando no botão Desabilitar  Proteção por Enquanto (Disable Protection for Now) [3].

Canvas em Dispositivos Móveis

A interface do Canvas foi otimizada para ser exibida em computadores, então, utilizando um dispositivo de tamanho reduzido como telefones pode não ser uma experiência agradável no uso do Canvas. Canvas não é oficialmente suportado em navegadores móveis. Nós recomendamos utilizar as aplicações móveis do Canvas para uma melhor experiência de usuário.

Como o Canvas usa pequenos elementos de Flash, nem todas as funcionalidades do Canvas podem ser suportadas em dispositivos móveis, especialmente no iOS.  

Navegadores Móveis

Visite a loja da Apple (Apple Store) ou a Play Store (Android) para fazer download de navegadores móveis. Os maiores navegadores a seguir são compatíveis com dispositivos móveis, mas funcionalidades do Canvas podem não ser suportadas:

iOS

  • Safari (navegador padrão do Canvas)
  • Chrome
  • Photon Flash Player (suporta Flash)

 

Android

  • Internet
  • Firefox
  • Chrome

 

Observação: O navegador padrão do Android varia de acordo com o dispositivo móvel.

You are here
Table of Contents > Especificações do Computador > Quais navegadores são suportados pelo Canvas?

Attachments

    Outcomes