AnsweredAssumed Answered

Unable to navigate out of a PDF in the Canvas iPhone app

Question asked by Nalaka Gooneratne on Feb 23, 2020
Latest reply on Feb 26, 2020 by Ryan.Seilhamer@ucf.edu

I've uploaded PDFs as reading assignments embedded in an ungraded survey. Students click on the file link in the ungraded survey instructions (the PDF file is in Canvas in the "Files" repository) and are taken to the PDF (note: the PDF is not a separate link in the module--it is embedded in the survey instructions).  There are two problems:

1. The PDF is very small and hard to read on the iPhone screen.  For some reason, it doesn't flip into landscape mode when I tilt the screen.  One can zoom, but it is hard to read across a complete line. 

2.  There is no way to get out of the PDF:  There are no buttons, etc., that take me back to the Quiz.  The only way to get out of the PDF is to force "stop" the Canvas app (by double clicking on the home button at the bottom of the iPhone and then swipping up to force stop the entire Canvas app).

 

I tried tapping everywhere on the screen, but there was no way to get out of the PDF.  If you have any suggestions, that would be appreciated. I'm attaching a screenshot; as you can see, there is no "back" feature to return to the quiz.

 

Update:  I also tried uploading a "text" file (I thought perhaps this was a problem with PDFs only) but it turns out there is also no way to get "out" of the text file and go back to the Canvas module--on the iPhone, there is no "back" button, so typically an app says "back" on the top left of the screen--I don't see this "back" button on the screenshot below  with the Canvas app). Thus, perhaps this is a problem with accessing any document in the "File" repository on the Canvas iPhone app?

 

Update 2: I next added the PDF to the Module (not to the Ungraded Survey instructions)--when I do this, I can see a "Back" button now.  So perhaps this problem only arises if the link to the file is placed into the Ungraded Survey instructions.

 

Update 3: I also tried creating a "Page" in Canvas and I copy/pasted the text into the Page.  I then inserted the link to the Page into the Ungraded Survey Instructions (Pages are listed on the right side of the screen).  Again, there was the same problem--no way to go back to the remainder of the Survey to answer the survey questions, etc.

 

This seems like a major issue, but it is odd that I couldn't find anyone else having this problem on the forum.  Perhaps I am missing seomthing simple?  My apologies if that is the case.

 

Outcomes