Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant LTI Tool Issues

I have the LTI tool configured on our site and it works in some contexts, but not others. Instructors adding documents to Canvas courses using Box works. Adding links to documents in the RCE works, etc.

Where the problem comes in is if an instructor clicks on the course menu placement for Box. This will open Box in a frame in the window, as if they logged into the Box site. They can click on folders to view files, and even drag/drop files from their computer into the window to upload files into Box. The problem comes into play when they go to share a file or folder from Box. It appears to work the first time you do it (if you've cleared all of you cookies from your web browser), and thereafter it displays a "An error occurred" pop-up window.

Looking for anyone else that has the app installed & is not having this issue. Thanks!

Tags (3)
6 Replies
Community Member

@MikeBrinkman Have you been able to solve this? I'm trying to set up the integration with Box and keep getting Oath errors after I add it to Canvas and attempt to view my files or the sad face. Trying to figure out what I'm doing wrong in getting it set up, or if it's related to the error you're getting. 

We solved it by removing the LTI placements from the user & course menus. 🤣

I was chatting with another admin at another college, and they said they had the same problem. I tried to report the issue to Box, but they said "Canvas is an external app, so we can't help you", even though it's Box's LTI.

In any case, using Box in Canvas works well enough if you use it the way I think they intended it to work, which is by choosing it from the RCE or as an external tool. The placement links are the problematic part.

We haven't experienced OAuth issues with our installation. Good luck, and make sure to follow up if you've solved it!


Community Member

@MikeBrinkman I was just able to successfully add it to the Course menu! But now I see what you're saying - when you're inside Box, click on Integrations, and then Send to Canvas, nothing happens. Mine just pops up a white screen and nothing happens. So yours gives an error? So you're saying if I take away Box from the Course tab on the left, that "Send to Canvas" works?

I don't recall seeing a Send to Canvas button, only a Select From Box button:


send to box.png

Oh, haha I see what you meant. Now I get those errors you mentioned 😂

This was what I was trying to figure out - what it did. 

Great chatting with you, by the way! 


It's interesting, I didn't know there was a send to Canvas option in Box. We only have Box installed on Canvas. Let me know if you figure anything else out on your end, and I'll update if I get a chance as well. 😉