Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant

Google Drive Integration LTI

Our team has created courses using the Google Drive Integration LTI. First of all, our district is Google App district. We are all about Google and every student has a district Google Drive account.  Logically we have built courses pulling content and activities via Google Drive.  We have create Google Cloud Worksheets for activities.  Here is the issue we are having, some students are not able to see the Google Cloud Worksheets while others in the same room see it.  

We have tried clearing the cache in the browser and still these students have the same issue.  

Has anyone else encountered this problem? If so, did you find a resolution.

Bill gaskins

13 Replies
Community Participant

The most common error we have with Google Drive and Canvas is students (and

faculty) who are logged into Google with their personal credentials and not

the school credentials - e.g., John Smith has a identity,

as well as a identity. He is logged into Google as When he tries to access something in Google Drive

through Canvas, it will most often fail, since items are commonly shared to

those in the domain "". Clearing cache doesn't help if they

authorized Google within Canvas while they were logged into their personal


On Tue, Nov 7, 2017 at 1:47 PM, <

Community Participant

We've been having an issue that sounds like the one you're describing. Canvas engineers are currently working on it but no resolution has been developed yet. Random students of ours will get double spinning wheels that never end and never result in a copy of the Google Cloud assignment (worksheet). Their Drives are authorized properly and they can see their other Google Drive files from within Canvas with no problem. The worksheet just won't materialize for them. It's frustrating because maybe a half dozen students out of 100 will have the problem and there seems to be no rhyme or reason as to why.

Here's a workaround that I've developed:

(1) Make a copy of the Assignment. (In the copy you'll need to connect that same Google doc again through the External Tool window in the editing screen.)

(2) Assign the copy to the students who are having problems with the original assignment.

(3) Have those students open the copied assignment. So far, we've had 100% success in getting the copy to work for those students.

(4) Now have those students go back to the original assignment and open it. Weirdly, the original assignment should now work for them. 

(5) If you look in their Google Drive, they now will have 2 copies of the worksheet (one from the original assignment and one from the copied assignment). So it may be wise to have them delete the copy that went with the copied assignment to avoid confusion later. The teacher can also delete the copied assignment from Canvas at this point.

Hope this helps!

Community Participant

We've been having the same issues for weeks with a few random students in a course not able to open a Google Cloud assignment. I'm told by our CSM that engineers are working on it, but since it is so random they aren't able to easily replicate. Be sure to open a case with Canvas support - I'm told the more reports they receive of the problem the higher priority it receives.

Community Participant

I've been having the same difficulty.  I also have students who have authorized their Google Drive but the embedded document, slides,... don't show up.  It's just a blank space.  This is happening with like 1 or 2 students in the class only.  I've checked to ensure they are logged in with their school email, and they are, so I'm not sure what to do next.

Community Participant

 @vcarmer   Try the workaround I described above and let me know if that works for you, too.

Community Participant

We have been having the same issues and have been working with our CSM and the engineers to resolve it.  We have tried multiple workarounds, but nothing is fixing it for all students.  

Community Participant

Hey Everyone, we got word today that Canvas engineers have deployed a fix for this problem. Fingers crossed - we're on Thanksgiving Break right now so we won't know if the fix was successful for us until early next week.

Community Contributor

We are a Chromebook district and while some of our students experience this same issue, our helpdesk folks have discovered that the issue is one of two things:

1.  too many tabs open in the browser

2.  student-installed apps and extensions.  The ones that cause the issue most often are games and multi-media apps / extensions such as music players.  Usually, when these are disabled, everything Google Drive related (and others) functions work fine.

Community Champion

Is anyone now running into issues using the LTI to add a Google Doc in the RCE or through Google Cloud? When I tested it, I was unable to load a doc into the RCE of a page or an assignment. It gave me a 414 Error-URI too large. This was a 3 line test doc that I've uploaded before. When I used the Google Cloud External Tool to add the document to an assignment, the error message says http_generic_error and that endless circle appears on the screen.