cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
millerjm
Community Champion

canvas-data-cli on linux?

Jump to solution

I'm having some issues installing on ubuntu linux.  I have the latest nodejs available for ubuntu - v0.10.37

Can anyone help with this? 

I get the following results when I install canvas-data-cli: 

root@canvasb:/home/millerjm# npm install -g canvas-data-cli

npm WARN engine canvas-data-cli@0.1.0: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.37","npm":"1.4.28"})

npm WARN engine hoek@2.16.3: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.37","npm":"1.4.28"})

npm WARN engine boom@2.10.1: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.37","npm":"1.4.28"})

npm WARN engine cryptiles@2.0.5: wanted: {"node":">=0.10.40"} (current: {"node":"0.10.37","npm":"1.4.28"})

/usr/bin/canvasDataCli -> /usr/lib/node_modules/canvas-data-cli/bin/canvasDataCli

canvas-data-cli@0.1.0 /usr/lib/node_modules/canvas-data-cli

âââ stream-stream@1.2.6

âââ async@1.5.0

âââ mkdirp@0.5.1 (minimist@0.0.8)

âââ pump@1.0.1 (end-of-stream@1.1.0, once@1.3.3)

âââ yargs@3.31.0 (decamelize@1.1.1, camelcase@2.0.1, window-size@0.1.4, y18n@3.2.0, os-locale@1.4.0, cliui@3.1.0, string-width@1.0.1)

âââ rimraf@2.4.4 (glob@5.0.15)

âââ request@2.67.0 (is-typedarray@1.0.0, aws-sign2@0.6.0, forever-agent@0.6.1, caseless@0.11.0, stringstream@0.0.5, tunnel-agent@0.4.2, oauth-sign@0.8.0, form-data@1.0.0-rc3, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, node-uuid@1.4.7, combined-stream@1.0.5, qs@5.2.0, tough-cookie@2.2.1, mime-types@2.1.8, bl@1.0.0, http-signature@1.1.0, hawk@3.1.2, har-validator@2.0.3)

âââ lodash@3.10.1

root@canvasb:/home/millerjm# canvasDataCli sampleConfig

/usr/lib/node_modules/canvas-data-cli/lib/logger.js:80

      throw _iteratorError;

            ^

ReferenceError: Symbol is not defined

    at Object.<anonymous> (/usr/lib/node_modules/canvas-data-cli/lib/logger.js:65:31)

    at Module._compile (module.js:456:26)

    at Object.Module._extensions..js (module.js:474:10)

    at Module.load (module.js:356:32)

    at Function.Module._load (module.js:312:12)

    at Module.require (module.js:364:17)

    at require (module.js:380:17)

    at Object.<anonymous> (/usr/lib/node_modules/canvas-data-cli/lib/cli.js:6:14)

    at Module._compile (module.js:456:26)

    at Object.Module._extensions..js (module.js:474:10)

Additionally, when I try to generate the config file, I also get errors: 

root@canvasb:/home/millerjm# canvasDataCli sampleConfig

/usr/lib/node_modules/canvas-data-cli/lib/logger.js:80

      throw _iteratorError;

            ^

ReferenceError: Symbol is not defined

    at Object.<anonymous> (/usr/lib/node_modules/canvas-data-cli/lib/logger.js:65:31)

    at Module._compile (module.js:456:26)

    at Object.Module._extensions..js (module.js:474:10)

    at Module.load (module.js:356:32)

    at Function.Module._load (module.js:312:12)

    at Module.require (module.js:364:17)

    at require (module.js:380:17)

    at Object.<anonymous> (/usr/lib/node_modules/canvas-data-cli/lib/cli.js:6:14)

    at Module._compile (module.js:456:26)

    at Object.Module._extensions..js (module.js:474:10)

1 Solution

Accepted Solutions
ccoan
Instructure
Instructure

Hey Joni,

Looks like you aren't running a new enough version of NodeJS This can be seen in the first line:

npm WARN engine canvas-data-cli@0.1.0: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.37","npm":"1.4.28"})

It's kinda unfortunate how Node, and NPM only give a warning message instead of a full stop error, as one would hope. As such you'll need to upgrade node to something that meets the requirements (as shown in the message >=0.12.0). If some applications still require using Node 10, I'd recommend using a version manager for node such as NVM. In order to satisfy the version requirement.

View solution in original post

3 Replies
ccoan
Instructure
Instructure

Hey Joni,

Looks like you aren't running a new enough version of NodeJS This can be seen in the first line:

npm WARN engine canvas-data-cli@0.1.0: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.37","npm":"1.4.28"})

It's kinda unfortunate how Node, and NPM only give a warning message instead of a full stop error, as one would hope. As such you'll need to upgrade node to something that meets the requirements (as shown in the message >=0.12.0). If some applications still require using Node 10, I'd recommend using a version manager for node such as NVM. In order to satisfy the version requirement.

View solution in original post

millerjm
Community Champion

Unfortunately, I'm running the latest version of nodejs for ubuntu.  My server admin said we can do some research on installing a not official version on ubuntu and see what happens so implementation on this is on hold for a while.  Smiley Sad

kevinw
Community Contributor

I ran into this problem using npm install method but did not run into this problem using the git clone install method.