cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pmichaud
Community Participant

what does it mean when there's no submission_fact entry for a submission_dim?

Jump to solution

I stumbled over these while trying to do some aggregate functions.  There are 45,588 entries in my submission_dim table that don't have a match in the submission_fact table.  Does this mean something specific?  Is it a data error?

Here is an example:

canvas=> select * from submission_dim where id = 100000024123908;

-[ RECORD 1 ]--------------------+---------------------------

id                               | 100000024123908

canvas_id                        | 24123908

body                             |

url                              |

grade                            | 2

submitted_at                     |

submission_type                  |

workflow_state                   | graded

created_at                       | 2015-05-01 05:52:55.666434

updated_at                       | 2015-05-01 05:52:55.666434

processed                        |

process_attempts                 | 0

grade_matches_current_submission |

published_grade                  | 2

graded_at                        | 2015-05-01 05:52:55.52155

has_rubric_assessment            |

attempt                          |

has_admin_comment                |

canvas=> select * from submission_fact  where submission_id = 100000024123908;

(No rows)

Since course, assignment, user and so on are in the _fact table, it's hard to tell what the source of this entry is.

1 Solution

Accepted Solutions
zac
Instructure
Instructure

Hi Patrick,

Seems like this is something I remember being an issue earlier this year, where the submission_fact and submission_dim tables didn't have the same count in the test instance I was using. Just checked today and the count currently matches up now. Can you let us know if you're still seeing this issue?

Thanks!

View solution in original post

1 Reply
zac
Instructure
Instructure

Hi Patrick,

Seems like this is something I remember being an issue earlier this year, where the submission_fact and submission_dim tables didn't have the same count in the test instance I was using. Just checked today and the count currently matches up now. Can you let us know if you're still seeing this issue?

Thanks!

View solution in original post