cancel
Showing results for 
Search instead for 
Did you mean: 
mfreedman3
Community Participant

Disappearing Graphics

Jump to solution

I have jpg images which display just fine, then for no apparent reason they disappear, only showing the file name.  Is this a bug? Am I doing something wrong?

279413_pastedImage_1.png

145 Replies
gordon
Community Participant

Running into the same problem when a quiz is passed from one course to another.  The attached images in the quiz need to package and move with the quiz.

I was able to replicate this using these steps. Thanks so much for outlining because I couldn't figure out what teachers were doing.

I'll pass it along to our CSM as well.

david_taylor
Community Participant

Great! Glad to hear it.  I just got a message yesterday afternoon that Instructure support was able to reproduce the issue and was opening a case with engineering.  And then a couple of hours later, some other support person said they were marking the ticket solved because there was a workaround (i.e. re-add the question, or something).  You'd better believe that I re-opened that ticket.  I have no idea why some other support person would come in and close a ticket--presumably without really reading the history or understanding the issue. That's what I've been fighting with.

Thank you david_taylor !

I have seen this kind of thing myself, especially as it relates to this disappearing graphics issue. When I am dealing with disappearing graphics in my courses, I usually send a list of previous support ticket/case numbers (mine and others that have been posted in the community) along with support request. It sometimes help to get the ticket moved up the chain a bit faster. I don't know how Canvas might go about making its support techs more aware of the history on this issue, but it would be nice if they could.

david_taylor
Community Participant

From the latest release notes:

"Question Bank Images

Images in edited questions associated with a question bank are retained in the quiz question.

 

Explanation: When a quiz question was added from a question bank, and the question was edited in the quiz, any images in the question were removed. Canvas code has been updated to not remove file verifiers associated with a quiz in edited questions."

I'd been in communication with our CSM and knew this went in last week.  I tested/verified and it appears that the fix works.  If you were seeing disappearing graphics in quizzes due to this error, it should be fixed.

Thank you again david_taylor! Fingers crossed Smiley Happy

So, is there any solution to this issue so far? We have a faculty reporting image disappearing again from one of the pages in Canvas.  Thanks. 

c_murphy
Community Participant

I was with a professor yesterday and witnessed the disappearing graphics on his course home page in Safari. Clearing cache was required to restore them as per the usual scenario with this issue. These were 4 very small images (less than 50kb). Since the graphics for that course act as the navigation menu this is not a cosmetic issue and I hate to disadvantage the students in this way. This problem actually means that course design will have to reflect concerns about this and be limited, so now we have a bug driving instructional design. And that doesn't even begin to touch on the issue this poses for quizzes. It's not happening in other systems, just Canvas, so it's clearly a Canvas issue.

mfreedman3
Community Participant

There have been attempts, but Canvas asks that you file a ticket through

your system admin... M

On Thu, Jan 10, 2019 at 6:29 AM c.murphy@gsa.ac.uk <instructure@jiveon.com>

saekow
Community Member

I am having the same issue, it is frustrating to build a site with images and then sometimes images do not load. The images I put into my site are important content, not just decoration.