Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mfreedman3
New Member

Disappearing Graphics

Jump to solution

I have jpg images which display just fine, then for no apparent reason they disappear, only showing the file name.  Is this a bug? Am I doing something wrong?

279413_pastedImage_1.png

149 Replies
cclo
Community Member

FWIW, recently two of our faculty independently reported that their course images don't display properly in their latest version of Safari but the images display fine in other browsers or in PCs. Clearing cache does not solve the problem. One of them is able to fix the issue by going to the Develop Develop menu in the menu bar, disable and then renable images, then refresh the page. (See Use the Safari Develop menu <https://support.apple.com/kb/index?page=link&apdid=sfri20948&viewlocale=en_US&bookId=El%20Capitan%20...>.) If you are seeing problems in Macs, perhaps give this a try?

jal18
New Member

I have been dealing with this issue for months. I would replace the images (housed inside the course under files) only to have it occur again and again. I had IT look into it; tried various browsers (with the most recent updates), cleared cache repeatedly but that only worked temporary. 

I found that Firefox is the only browser that consistently displays images. However,  this doesn't really solve the issue. Learners will use their preferential browser which means that images may not display properly thereby, reducing the quality of course and possibly damaging the relationship we are building with learners.

wturgeon
New Member

This is a helpful thread.  I found using a different browser helped but we cannot ask students to switch browsers or refresh their pages.  I hope this can be fixed.  

Wendy

jbrown10
New Member

Hi Michael,

You are not doing anything wrong. This has been an ongoing issue for the better part of 8 months. I think I first noticed it in December 2017, others noted it happened before then from memory.
there is a much more complete discussion with links to numerous other cases reporting the same issue that can be found: https://community.canvaslms.com/thread/20989-why-are-my-jpeg-images-disappearing 

For me currently, I notice the images disappearing some days however after navigating around canvas, doing some work, and not touching them, eventually, they pop back up. 
Clearing cache/cookies doesn't fix anything, it happens across multiple computers/browsers. 

Does anyone else find that images re-appear of their own accord after a few hours?

MollyCaldera
Community Member

I was experiencing this issue today and yesterday as well. I switched to Chrome over Safari long ago because my images were appearing as broken images. It seemed to work for me. Then just recently I saw the images broken. It was intermittent though. So, for example, the page banner would indicate it was a broken link, then it would reappear for me with no issues. Very strange. 

I did just have a computer update, though. What are the odds we are all working on a Mac though? Probably not. 

The big takeaway from my observation is that the images did reappear. It was very strange.  

kimberly_smith1
Community Member

This is an ongoing issue in Canvas - popping up for years now. Unfortunately, there has been no permanent fix so far. I haven't collected data on it, but it seems to me that the timing for when this issue emerges may be associated with New Releases? Here are just a few links to previous occurrences.

To get Canvas engineers to look at this (e.g. beyond L1 or L2 help), it seems important to communicate the scope of the recent emergence of the issue. The only way I know to do this is for those experiencing it to try and coordinate regarding Problem Report submissions. It is a hassle, but I have seen it work in the past....

Person A submits a Problem Report and then posts their case number to the most recent Community discussion on the issue. Then Person B includes Person A's case number in their own Problem Report submission, and follows up by posting their case number to the community, Then Person C includes case numbers from Person A and Person B in their Problem Report submission, and follows up by posting their case number, and so on.

Canvas tech support continues to maintain this is a cache issue. Here is the

updated comment and my reply.

Meghan, the thread includes examples and screenshots of disappearing

graphics.

Correct me if I am wrong, Clearing the cache means that all of my cookies

get cleared and I will have to re-login to all of my sites each time I do

this. A terrible inconvenience for me and all of my students. So much so

that I will not want to put images in my courses! Isn't there a better way?

On Thu, Jun 21, 2018 at 7:21 PM, caldera@sxu.edu <instructure@jiveon.com>

mfreedman3
New Member

I've escalated to my CSM team:

Thanks, Quinn,  I want to reiterate two points:

1) Clearing cache, even if it works temporarily, is not a realistic solution. This impacts everyone and is an inconvenience. When you clear your cache as directed, your entire browsing history, cookies, and passwords are deleted. All users will then periodically have to re-sign into each of their websites.  A royal pain if not the extremely rare occurrence.  Very annoying if happens even occasionally.  Do you really want all Canvas uses to have to do this? 
2) This reflects poorly on Canvas. I know of no other SaaS application that asks its users to clear their cache on a regular basis or even occasionally. 
There has to be a better way to deal with this other than put the work on all of our customers.
Best,
Michael

 @mfreedman3  

I'm sorry this feels like a struggle to you, but I can assure you that we're all here to help find the best solution.  Making your CSM aware is great, but I'd also encourage you to follow up with the support ticket and help them escalate and research/troubleshoot further.

To you're point #2, I have found that it is very common to try/recommend a cache clear as the first troubleshooting activity; browsers do funny things.

Support folks have a baseline of troubleshooting questions that they start with, so what the support person sent you wasn't for lack of trying, they have to start somewhere.  What I haven't seen in this thread is if you have actually tried a different browser or a different computer when you are seeing this issue yourself?  I know that your students are experiencing this sometimes, and it's more difficult to troubleshoot with them.  This is why I ask if you have tried it?

There is also a chrome add-on that you might want to try?  Stefanie found this tool not too long ago and it has worked fabulous when we've needed to troubleshoot cache/cookie issues with Jive for our community users.  EditThisCookie - Chrome Web Store 

Rene, thanks for mediating.

I am copying progress to both sources: keeping those in this

thread informed of tech support's suggestions, and sharing comments from

this group in the ticket (#03211628). Are you able to see the ticket?

I am not playing one group against the other but trying to bridge the

structural divide that exists between the community forum and the help desk.

You can see in the community thread some frustration (help desk is

stonewalling). Please understand that I am pursuing this from a 'we're in it

together' posture. We both, collectively, have the same customers and want

Canvas to be flawless.

My take is that this is a tricky, occasional issue that needs attention.

Consider this argument: even if clearing the cache is the solution, do we

(Canvas and Canvas customers) want to have to periodically tell our users

that this is the solution? It is a significant inconvenience. As I said, I

know of no other Saas Application that has this problem. So, even if it is

the nature of JPGs on Canvas to occasionally disappear, then it is a design

opportunity to solve. As the provider, I believe Canvas has to take

ownership of this and ferret out the solution or come up with an alternate

design.

Michael

On Fri, Jun 22, 2018 at 7:57 AM, Renee Carney <instructure@jiveon.com>