cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
u0291895
Community Participant

SCORM file won't display in module or assignments

Help!

I'm having an issue issue with a SCORM file. I've never had problems before. I can see the file just fine from the SCORM page, but it won't display from modules or the button on the homepage I've linked to the assignment.

The assignment and course are published. I'm in Chrome.

Any ideas?

Thank you!

SCORM.Canvas.png

Tags (1)
9 Replies
sjohnsonpoly
Community Participant

Hi Elizabeth,

Did you upload your zipped SCORM package via the SCORM Player in Canvas? This happened to me once, I uploaded again using Firefox and it worked. My guess is a glitch happened that broke the link to your package. Not a biggie, just a fluke issue. Try uploading your package again and delete the old one. Smiley Happy

Reiterating the point to check that you uploaded a zipped scorm package and not an unzipped file.  That makes a difference.

u0291895
Community Participant

Hello again.

I am back to trying to upload a SCORM file and getting the same response from Canvas. I have tried Chrome, Edge, and Firefox. I have also tried uploading at a graded and non-graded assignment. Oh, also, it is zipped and I am using the SCORM tool. 

Any other ideas? 

Thank you!

gailc
Community Participant

Hi Elizabeth -

I utilize SCORM packages frequently in Canvas without issue. Could it be browsers need updating? If you would be willing to share files I can attempt on my end to see what the issue might be. Just to clarify you can see SCORM content within the SCORM window and you have linked from the SCORM page - correct?

Gail

sjohnsonpoly
Community Participant

Hi Elizabeth,

I am also happy to try your package and see if I find anything.

Thanks…

Scott Johnson

Instructional Design Engineer

Canvas LMS Admin

RAD Makerspace Engineer

Florida Polytechnic University

W: 863.874.8882

4700 Research Way #1057

Lakeland, FL 33805-8531

sjohnson@flpoly.org<mailto:sjohnson@flpoly.org>

u0291895
Community Participant

I had a friend add both SCORM files to a new course in different sub-account and it worked!  She also tried to add it to my course in my sub-account and she got the same error. Isn't that weird?

Thank you for your help!

sjohnsonpoly
Community Participant

Is the SCORM LTI enabled for the main account as well as the Subaccounts?

Scott Johnson

Instructional Design Engineer

Canvas LMS Admin

RAD Makerspace Engineer

Florida Polytechnic University

W: 863.874.8882

4700 Research Way #1057

Lakeland, FL 33805-8531

sjohnson@flpoly.org<mailto:sjohnson@flpoly.org>

LauraFIU_IDT
Community Member

Hello,

I'm experiencing the exact same issue. I regularly upload a SCORM to the same course and have never had issues. I've tried both Chrome and Firefox. It seems to freeze when I  click Go to import as graded assignment. It eventually becomes available but doesn't find the assignment.

 

Could it be a space/size issue for the course?

 

The exact same issue is happening with me. Just started a few days ago. I have about a 68 MB Articulate Storyline file, and I also tried a 12 MB file that I uploaded last week, and no success. Here is everything I tried and thought of:

- I tried publishing to Scorm 2004 as well (before I would export to Scorm 1.2).   

- Checked launch URL, as well as all credentials (secret key etc) for the Scorm app at the main account level

- Tried uploading in different courses, brand new blank courses. 

- Created a 2 MB file but exporting text box and a shape, failed to upload (just gets stuck at the "go" button like you say")

- Funny thing is, the course is fine: 

I am able to view it and complete the content (everything works) in the Scorm section, of Canvas (clicking on the eye icon). I am also able to view it on Scorm Cloud with no issues, as well as publishing to Review 360, video and web.

I am not sure what to do anymore. Someone from Canvas, please help!