cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dtygel
Community Member

Failed to build canvas-android

Jump to solution

Documentation about building canvas-android, in github, is not working.

I've tried the steps described in the readme.md file:

./gradle/gradlew -p apps :student:assembleDevDebug

And then got the following result/error:

> Configure project :

============= MERGE PRIVATE FILES: ALL-APPS ================
Merging private.properties:
pspdfMavenUser
pspdfMavenPass
============================================================


> Configure project :annotations

============= MERGE PRIVATE FILES: ANNOTATIONS =============
Merging private.properties:
pspdfMavenUser
pspdfMavenPass
============================================================


> Configure project :canvas_espresso
dittoMode: play

> Configure project :login-api-2

============= MERGE PRIVATE FILES: LOGIN-API ===============
Merging private.properties:
anonymousSchoolDomain
============================================================

Copying Snicker Doodles
Snicker Doodles Do Not Currently Exist

> Configure project :panda_processor
'kapt.generateStubs' is not used by the 'kotlin-kapt' plugin
'kapt.generateStubs' is not used by the 'kotlin-kapt' plugin
'kapt.generateStubs' is not used by the 'kotlin-kapt' plugin
'kapt.generateStubs' is not used by the 'kotlin-kapt' plugin

> Configure project :student

============= MERGE PRIVATE FILES: STUDENT =================
/var/www/html/grit/canvas-android/apps/student/src/main/res/xml/analytics.xml exists and is UP-TO-DATE
Merging private.properties:
crashlyticsApiKey
pspdfMavenUser
pspdfkitLicenseKey
pspdfMavenPass
newRelicAppToken
/var/www/html/grit/canvas-android/apps/student/src/main/res/values/private_strings.xml exists and is UP-TO-DATE
/var/www/html/grit/canvas-android/apps/student/fabric.properties exists and is UP-TO-DATE
/var/www/html/grit/canvas-android/apps/student/newrelic.properties exists and is UP-TO-DATE
/var/www/html/grit/canvas-android/apps/student/google-services.json exists and is UP-TO-DATE
============================================================

Excluding compile dependency: kotlin-android-extensions-runtime

> Configure project :teacher

============= MERGE PRIVATE FILES: TEACHER =================
Merging private.properties:
pspdfMavenPass
roboTestDomain
fabricApiKey
versioneye.api_key
roboTestUserToken
versioneye.projectid
pspdfkitLicenseKey
pspdfMavenUser
roboUser
/var/www/html/grit/canvas-android/apps/teacher/fabric.properties exists and is UP-TO-DATE
/var/www/html/grit/canvas-android/apps/teacher/google-services.json exists and is UP-TO-DATE
============================================================

Build report logic aborting due to failed build

FAILURE: Build failed with an exception.

* What went wrong:
Task 'assembleDevDebug' not found in project ':student'.

* Try:
Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.6.2/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 2s

It simply says that assembleDebug doesn't exist. I've tried the same with :teacher and : parent, and had exactly the same error.

I've also tried to compile in Android 4, to no avail.

Is there something I'm missing or missing in the Documentation?

Thanks.

Tags (1)
1 Solution

Accepted Solutions
narmstrong
Instructure
Instructure

Those docs are a little bit out of date. You shouldn't have to run those tasks anymore. Just select the app that you wish to run from the list of configurations and click Run.

I've updated the docs in this pull request Update build section of README by armstrongnate · Pull Request #916 · instructure/canvas-android · G... 

View solution in original post

1 Reply
narmstrong
Instructure
Instructure

Those docs are a little bit out of date. You shouldn't have to run those tasks anymore. Just select the app that you wish to run from the list of configurations and click Run.

I've updated the docs in this pull request Update build section of README by armstrongnate · Pull Request #916 · instructure/canvas-android · G... 

View solution in original post