cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rerwin789
Community Participant

Broken links to images when importing a course

Jump to solution

I have some images that were embedded using the rich text editor.

When I import the module into another course, the images show as "broken links." How do I prevent this?

Thank you!

Tags (1)
1 Solution

Accepted Solutions
Bobby2
Community Coach
Community Coach

Hi  @rerwin789  Welcome to the Canvas Community.

When a module or course is copied, as long as the images have been inserted using the Content Selector, and as long as all of the items in the course (including the course files) have been copied as part of the course copy process, images should come along in the copied course, and the relative links created when the course was first constructed will remain intact. Please refer to How do I insert course images into the Rich Content Editor using the Content Selector?

 

Perhaps explore how your original images were added. Then how the courses are being copied. 

Sing out if you need a hand. 

View solution in original post

0 Kudos
5 Replies
Bobby2
Community Coach
Community Coach

Hi  @rerwin789  Welcome to the Canvas Community.

When a module or course is copied, as long as the images have been inserted using the Content Selector, and as long as all of the items in the course (including the course files) have been copied as part of the course copy process, images should come along in the copied course, and the relative links created when the course was first constructed will remain intact. Please refer to How do I insert course images into the Rich Content Editor using the Content Selector?

 

Perhaps explore how your original images were added. Then how the courses are being copied. 

Sing out if you need a hand. 

0 Kudos
acolvin
Community Participant

This happens every once in a while. If all else fails, download the images from the previous shell and upload them into the new course's files. Make sure they have the same file names. 

lesley_cryderma
Community Contributor

Lately this is NOT working. It's also not working in Copy to and Direct Share. And since the html points to the file location rather than the file name, they all have to be reconnected. The only time this seems to work is when doing an entire course import.

Hi  @ , this does not sound as it should. 

Perhaps it's time to contact Canvas Support.

george_franz
Community Participant

This is an ongoing issue, and has been for years.  When trying to export questions or a question bank, you typically export the course or a quiz - you may also "copy course" if it is your course.  None of these methods export the actual images in any consistent basis.  They export links to the images in the course it came from.  If you look at the html and see the "verifier" in the image source, you know that it is linking to another course.  That works most of the time, as long as the other course exists and you don't change your questions in any way.  Edit them once though, and all those images are gone.  It's a horrible way for canvas to try to save space by including links to images rather than the images themseles.  It reduces sharing question banks to a crap shoot whenever there are images involved.