cancel
Showing results for 
Search instead for 
Did you mean: 
brian_runo
Community Participant

Bug with loading Pages section - 4K+ Monitor

Is anyone else having this issue?

Browser: Any Browser

OS: OS X 10.11.6

Resolution: 3200 X 1800

So I think I found a bug in how the pages section is rendering on high resolution monitors. Essentially, when I have my browser window above a certain height, specifically when I can see the "loading now" with the spinning icon on the bottom and have room underneath, it stops loading my pages. The workaround I found was to reduce the height of the browser window to slightly below the "loading now" icon at the bottom even just momentarily so that the page links will load. You can see a screencast of the issue and the workaround here: Canvas Pages Bug

This will occur on Chrome, Firefox, or Safari whenever the height is too big like if I want to make it take up half of my screen or use the OSX maximize button.

34 Replies
brian_runo
Community Participant

I haven't found an answer to the question since Canvas still has not updated their back-end code to fix this problem. 

hydeag
Community Participant

This is still an issue.  Arrows just keep spinning with no results.  And I am not on a 4K monitor. I'm on a HP 2408 (24 inches).

brian_runo
Community Participant

YEP!! and it's apparently marked as answered because I provided a workaround here. 

brian_runo
Community Participant

 @Robbie_Grant ,

The issue still persists and the code hasn't been fixed, so the issue is still occurring. This should not be marked as answered or assumed answered

 @brian_runo ‌, it was marked as Assumed Answered because (1) there were responses provided to what the issue is and how it can be address and (2) you did not indicate that there was anything further to pursue on the matter.

As  @Robbie_Grant ‌ indicated when he asked, "Have you reported this to Instructure Support?" there is nothing the community can do to actually fix this, nor is the community the proper place to seek Instructure-provided support. That doesn't mean you can't get it here.

You indicated that you did submit a ticket to Instructure Support. Responding to that ticket would be the appropriate place to seek an update on a resolution to the issue. Please, provide any updates you're comfortable posting with the rest of the community, but when the issue is resolved it'll be resolved for everyone as part of the update cycle. As such, the direction to contact Instructure Support and the subsequent workarounds can be considered as the answers to this. At least, that's my interpretation of the situation.

If you would like a more robust workaround, I could probably write a script that will rebuild the page without the 30-entry initial limit, though that's still not a solution to the underlying issue that can only be addressed by Instructure.

Stefanie
Community Team
Community Team

 @brian_runo , you're absolutely right, and because this is still an ongoing case with Support, we've changed the status of the question from 'assumed answered' to 'unanswered.' When you receive notice of a resolution from Support, we'd appreciate it if you would take the time to post an update here. Thanks!

Hello  @brian_runo ...

I thought that I would check in with you one more time because there hasn't been any new activity in this thread for over two months.  Did you ever receive a response from the Technical Support people at Instructure to see if they will (or have already) work on a fix for this?  As stefaniesanders‌ suggested, please come back here to provide an update for us so that we can know if this has been resolved or not.  Thank you.

brian_runo
Community Participant

I have not received any updates other than people asking if I have received any updates. The issue, which you can check on an iMac, is still not resolved. 

Robbie_Grant
Community Coach
Community Coach

 @brian_runo ,

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.

 

Robbie

smott
Community Member

The problem is still recurring. I confirm that the workaround of shrinking the vertical height of the window and then maximizing it again does work, but it took a long time to figure this out. I'd rather have a "Load More" button if needs be where I can manually trigger the display of additional pages than rely on an automated script that may not be triggered because my monitor is "too awesome." Smiley Happy