Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Member

Can't swipe consistently in Canvas Teacher App speed grader

I occasionally would have trouble getting the screen to swipe, but now it's almost impossible. I have to select "Done" after each student which defeats the "speed" part of speed grader. Also, there are annotation tools on the top of some assignments which I can select and unselect to override the lack of swipe (it then works) but they are not on all assignments. 

I hope this is an error as this was one of my favorite features as it really expedited my posting of grades.


14 Replies
Community Team
Community Team

Hi ~ Are you using an iOS or Android device? How long have you experienced this issue?

New Member

I'm iOS and I am having this same issue.  

Community Team
Community Team

Hi Lori and Amber - I wanted to take a minute and circle back to this conversation. With the more recent updates to Canvas Teacher, I'm wondering if you still experience the challenge of swiping between assignments. Either way, it would be great to hear from you.

Community Team
Community Team

Hello! I recently double-checked this, and it seems to be functioning correctly for me. I hope that one of the updates fixed it for you as well. Because there hasn't been activity in this thread for a while, I'm going to mark it as "Assumed Answered". (How we keep your questions flowing!‌) The label won't prevent you or anyone else from commenting, however. 

Hi Kristin,

This is still a problem for me on an iOS device.  I have no outstanding updates on the iPad, so any updates didn't solve the problem.  I can't predict when the swipe to next student feature will work vs not work, but if I don't annotate the document at all and just swipe to the next student, there doesn't seem to be a problem.  I will update this message if I see more patterns so hopefully the bug can be fixed.

 @KristinL ‌

I tested a few scenarios on my iOS device (iPad).  

When swiping doesn’t work:

After I annotate the document and don’t assign a grade.  

If I annotate the document and then use “+” key to manually assign a grade (needed for decimal grades).

Note: if I enter text with the text option rather than use my finger or stylus to annotate, then the swiping works.


When swiping does work:

If no annotation or grade is entered.

If no annotation is entered and then use “+” key to manually assign a grade (needed for decimal grades).

If I annotate the document, but then use the sliding scale to assign a grade.

I know this is an older post, but I have the same issue.

My students had a take home test that they have uploaded (because they need to be able to print it out if they want and they can upload an image or scan of a printed out version so I can see their work, not just the final result). This is for a Latin class.

The problem is, for consistency I grade one question at a time. So, I have to annotate, then click done, then click on another student because the swiping feature does not work. If I can figure out how to make it work, I will let you know. I am using iOs 13.3.1 and have autoupdate on, so all the software is updated.

Community Participant

I am having the same issue as well.  I grade one page at a time and having to click Done and reload a new student's exam takes more time than I save by being able to annotate with my Apple pencil.  If I don't annotate then I can swipe but that defeats the purpose.

I am playing some more.  I click on the pen, make my annotations, then turn off the pen, then go to the top in the white space between the student's name and "Done" and I can I can make it work, but swiping only works in this specific space after I have annotated the exam.

 @acgottfr ‌ thank you!

Turning off the pen worked for me just now.