cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Can-vas_999
Community Member

Canvas Studio Demo

Jump to solution

I know how to make a Canvas demo and embed it. I do not want the comments feature on. I keep turning it off but it still appears in student view. I do not want to field questions about why they cannot comment. I just want the comments to go away.

Labels (1)
0 Kudos
1 Solution

@Can-vas_999 ...

If you can, please make sure that you are replying to things below the newest comments...as the conversations are easier to follow that way.  Now...on to your questions.  I'm assuming some things about your process, so hopefully this is close to what you are doing...

When you click on the "Studio" button on your left-hand global navigation menu in Canvas, you click on your video.  Then, you click on the cog wheel ("Settings") icon on the lower right-hand corner of the video.  You then toggle the "Comments" switch to "off" (gray).  I also did this, but every time that I left the Studio screen (for example, returned to my Canvas Dashboard) and then returned to that video in my Studio library, the "Comments" toggle switch went back to "on" (green).  I realize this is not what you are looking for, and it seems like it would be unexpected behavior for the functionality of that tool.  However, I think things still might not be clear for you..and maybe that was because of my explanations (it's hard to convey some things at times when typing vs. verbally)...so I'll try and explain...

Based on everything you've described in this topic, all you really want is for the Studio video to be displayed to you and your students as an embedded video in your course...without all that discussion interface below it.  The fact that you are trying to turn "off" (gray) the "Comments" toggle switch isn't something you need to continue to worry about and/or try and troubleshoot.

  1. Log into your course, and edit the page where you want to embed your video.  (Again, if the video is already embedded on a page in your course and it is displaying the discussion interface below it, you'll want to remove it first.)
  2. Embed or re-embed the Studio video onto your course page.  Follow these instructions to embed the video into your course content page...being sure to keep the toggle switch for "Display Media Tabs" option turned "off" (gray): How do I embed Canvas Studio media in a Canvas cou... - Instructure Community (canvaslms.com).  Once the video has been embedded in a course page, you will only see the video and not the discussion interface below it.
  3. Save the content page.

After saving the video, you'll still be able to click on the cog wheel ("Settings") icon within the video and see the "Comments" toggle switch, but it won't affect anything.  You won't see anything different if you toggle it on...and neither will your students.  In my screenshot from my own course, I tested this out looking at it from both a Teacher and a Student perspective.  This is what I see after my Studio video has been embedded...

Screenshot 2022-08-23 173921.jpg

As you can see, there is no interface below the video because I chose to leave the "Display Media Tabs" toggle switch turned "off" (gray).  But both Teachers and Students can still click on the cog wheel to select the "Comments" toggle...even though it won't display anything to anyone.  The "Display Media Tabs" toggle switch has to be turned on in order for the "Comments" to work.  Further, both Teachers and Students would have to be able to use the discussion interface below the video in order for the "Comments" to do anything.  All the "Comments" toggle switch does is displays comments from people on top of the video in little chat bubbles...similar to the top-half of the screenshot shown under the heading "Student and Instructor Engagement" in this Guide: What is Canvas Studio? - Instructure Community (canvaslms.com).

I hope I am understanding your question correctly and that my explanation is clearer.  If not, would it be possible for you to record a screenshot of what you are doing so that I could see exactly what your process is?  I think we are close to being on the same page...but maybe a quick recording would help?  Hope to hear back from you soon!

View solution in original post

0 Kudos
12 Replies
Chris_Hofer
Community Coach
Community Coach

@Can-vas_999 ...

Are you talking about the "Comments" toggle option via the "Settings" icon (cog wheel) when you click on an embedded Studio video in your course?  If so, that is for in-line comments.  You'd also have to have the "Display Media Tabs" toggle switched on (green) when deciding to embed the Studio video on your page...in order to also use that "Comments" toggle switch.  So, if you aren't using the "Display Media Tabs" option, the "Comments" won't have much use.

Does this help to answer your question?

0 Kudos

Sorry, really.  I sent screenshots. I see no Display Media Toggle switch. I I turned off comments before I made the video. I made sure when I embedded it that the comments were set to gray, not green. But as you can see from the screenshot of the page on which I embedded the video, that the screen contains words that say “no comments yet” indicating that there is a Comments feature. I DON'T want that to be visible to students, or myself for that matter. I want no comments to be visible. Must I create a video and toggle OFF display media?

0 Kudos

@Can-vas_999 ...

If you can, please make sure that you are replying to things below the newest comments...as the conversations are easier to follow that way.  Now...on to your questions.  I'm assuming some things about your process, so hopefully this is close to what you are doing...

When you click on the "Studio" button on your left-hand global navigation menu in Canvas, you click on your video.  Then, you click on the cog wheel ("Settings") icon on the lower right-hand corner of the video.  You then toggle the "Comments" switch to "off" (gray).  I also did this, but every time that I left the Studio screen (for example, returned to my Canvas Dashboard) and then returned to that video in my Studio library, the "Comments" toggle switch went back to "on" (green).  I realize this is not what you are looking for, and it seems like it would be unexpected behavior for the functionality of that tool.  However, I think things still might not be clear for you..and maybe that was because of my explanations (it's hard to convey some things at times when typing vs. verbally)...so I'll try and explain...

Based on everything you've described in this topic, all you really want is for the Studio video to be displayed to you and your students as an embedded video in your course...without all that discussion interface below it.  The fact that you are trying to turn "off" (gray) the "Comments" toggle switch isn't something you need to continue to worry about and/or try and troubleshoot.

  1. Log into your course, and edit the page where you want to embed your video.  (Again, if the video is already embedded on a page in your course and it is displaying the discussion interface below it, you'll want to remove it first.)
  2. Embed or re-embed the Studio video onto your course page.  Follow these instructions to embed the video into your course content page...being sure to keep the toggle switch for "Display Media Tabs" option turned "off" (gray): How do I embed Canvas Studio media in a Canvas cou... - Instructure Community (canvaslms.com).  Once the video has been embedded in a course page, you will only see the video and not the discussion interface below it.
  3. Save the content page.

After saving the video, you'll still be able to click on the cog wheel ("Settings") icon within the video and see the "Comments" toggle switch, but it won't affect anything.  You won't see anything different if you toggle it on...and neither will your students.  In my screenshot from my own course, I tested this out looking at it from both a Teacher and a Student perspective.  This is what I see after my Studio video has been embedded...

Screenshot 2022-08-23 173921.jpg

As you can see, there is no interface below the video because I chose to leave the "Display Media Tabs" toggle switch turned "off" (gray).  But both Teachers and Students can still click on the cog wheel to select the "Comments" toggle...even though it won't display anything to anyone.  The "Display Media Tabs" toggle switch has to be turned on in order for the "Comments" to work.  Further, both Teachers and Students would have to be able to use the discussion interface below the video in order for the "Comments" to do anything.  All the "Comments" toggle switch does is displays comments from people on top of the video in little chat bubbles...similar to the top-half of the screenshot shown under the heading "Student and Instructor Engagement" in this Guide: What is Canvas Studio? - Instructure Community (canvaslms.com).

I hope I am understanding your question correctly and that my explanation is clearer.  If not, would it be possible for you to record a screenshot of what you are doing so that I could see exactly what your process is?  I think we are close to being on the same page...but maybe a quick recording would help?  Hope to hear back from you soon!

0 Kudos

Chris,

Worked! it was the embedding process that hung me up. I did not LOOK at the  "Display Media Tabs" because i thought it meant display the demo itself.

Sorry I made you go thru all that. I simply downloaded the demo I already made. Re uploaded it to Studio. Made a page, embedded it and then replaced the demo in the INTRO page.

Thanks a million.

JD

0 Kudos

@Can-vas_999 ...

I am glad that you were able to get things working on your end, JD!  That is great to hear!  I hope your semester gets off to a good start!  Take care...

0 Kudos

Chris,

I can't believe I don't know the answer to this question, but can students not edit their own discussion posts? I believe that function was once enabled but now I do not see it.

 

JD

0 Kudos

@Can-vas_999 ...

That's a setting that you can control within your "Settings" page of your course.  When in your "Settings" page, scroll all the way down to the bottom of the page, and then click on the "more options" link.  There will be a check box for "Let students edit or delete their own discussion replies".  Click on the "Update Course Details" button when you make any changes to that page.

There is another way to do this, too.  Here's the Guide: How do I allow students to edit and delete their o... - Instructure Community (canvaslms.com)

Hope this helps!

Thanks a million
Can-vas_999
Community Member

I DO NOT want the COMMENTS feature toggled to GREEN. I want NO comments feature to appear in student view AT ALL>

0 Kudos

@Can-vas_999 ...

As I had mentioned in my initial response...  if you have the "Display Media Tabs" toggle switch turned "off" (gray) when you first embed the Studio media in a content page in your course, that "Comments" toggle switch within the "Settings" (cog wheel icon) of the video won't have any affect.  So, if you and your students never had any comments on the video to begin with, they won't see any comments even if that "Comments" toggle is switched "on" (green).  The "Comments" toggle seems to be only connected to the fact that the "Display Media Tabs" option also has to be turned "on".  So...in summary, leave the "Display Media Tabs" option turned "off", and you won't have to worry about any comments showing up on/under the video.  Does that help?

0 Kudos
Can-vas_999
Community Member

Excuse me but I saw no display media switch, neither when I made the video nor when I embedded it. In the past I have made videos and turned the comments feature OFF when I was making it--as I did this time--and it did NOT show up. This time it shows up in student view. That means students will WANT to make comments and I will have to EXPLAIN why they cannot. Must I create the video from scratch to make sure display media is OFF???

0 Kudos

@Can-vas_999 ...

Hello again.  Thank you for sharing your screen shots.  However, I am not sure if some of those screenshots you shared are from when you click on the "Studio" icon on the far left-hand side global navigation menu?  It seems to me that at least the first image, "I do not want students...", comes from that screen...but I'm not 100% sure because you didn't include that in your screenshot.  In any case...please see below.

As you follow this Guide to embed your Studio media into a content page of your course, How do I embed Canvas Studio media in a Canvas cou... - Instructure Community (canvaslms.com), you should see a toggle switch to "Display Media Tabs".  I know you said you didn't see this, but I'm not able to re-produce this on my end.  It should be there for everyone.  (I even checked some admin settings in Studio, and there isn't a way to "hide" it from people.)

In your image called "I see no display media switch", that image is *after* you've already embedded the Studio media on your page.  You would need to use the link I included in the above paragraph to embed your video onto the page...and that is where the "Display Media Tabs" option is available to you.  If you do not want that comments interface with the "Details", "Comments", "Insights", and "Captions" tabs (below the video) to display on your screen, then you will need to first remove the video from your content page and then re-embed the video...making sure to leave the toggle for "Display Media Tabs" turned "off" (gray).  (When you edit the page with the Studio video, just place your cursor at the bottom right corner of the video interface...similar to clicking somewhere to type), and then hit the Backspace key on your keyboard.  The video should be removed from the page.  Now, re-embed.)

For your last image, "I turned the comments toggle OFF", I think this will all be resolved if you follow the directions I've outlined above.  Again, as I had stated in my previous postings...that "Comments" toggle switch will still allow you to toggle it "on" and "off", but once you re-embed the Studio video with the "Display Media Tabs" option turned "off", then that "Comments" toggle will not apply any more.  In a way, the "Display Media Tabs" toggle has to be enabled for the "Comments" toggle to actually do anything...if that makes sense.


Must I create the video from scratch to make sure display media is OFF???

No...you shouldn't have to create a new video from scratch.  Just re-embed like I've described above.

I apologize if I was not clear in my earlier postings...but I hope that this response has helped to clarify things for you.

0 Kudos