Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Champion

Class Notebook plugin not working

Jump to solution

Anyone else getting errors when installing the class Notebook plug in for OneNote2016. Can link to Canvas instance but get error when trying to do any mapping of classes, creating assignment etc:


Class Notebook plugin works fine when creating students and you can open the OneNote in OneNote app and OneNote 2016. Issues occur when you try to push things from OneNote back to Canvas via the plugin. Issue seems to have arisen in the last 3 weeks or so as mapping fine last semester.

1 Solution

Accepted Solutions
Community Participant

Microsoft released version 1.8.4 of the Classroom Notebook LTI today and this has fixed the problem for Clemson.  Hopefully it will resolve the problem for everyone else as well.

To install the new version:

  1. Open OneNote
  2. Click the Class Notebook tab
  3. It should prompt you to install the new version

Happy Friday!


View solution in original post

11 Replies
Community Member

Yes. We are seeing this as well.

Community Champion

Contacted Microsoft Tech Support. Have now been given a number of Microsoft (Customer Care) to look at matter. Now posted question on their Help Forum - Microsoft Community 

Community Champion

Issue now raised with Class Notebook Support and email sent to them with screenshots and details of error code.

Community Champion

I did not know this was a problem.   Thank you for sharing this here.

Community Champion

Further Update: 18th Sept

From Microsoft Engineer

Hello Gideon, Thank you for reaching out to us regarding your issue. Our engineering and development team are aware of this issue and are wanting to reach out to you for a call. Could you please provide your contact information for and Skype or phone call to further investigate your issue?

Community Participant

Here is what we have determined and reported to Microsoft.

  • When Microsoft released version 1.8.2 of their Classroom Notebook it broke all OneNote versions we were currently using.  From the Canvas side as well as the OneNote side.  Meaning when you clicked on Class Notebook from Canvas it gave you the below error message and would not connect to the OneNote Classroom Notebook.  If you clicked on Manage Notebooks from the OneNote Classroom Notebook ribbon, you got the above error message. 

Almost There

We need more information from your LMS so we can get everything set up correctly.

Please ask your IT administrator to check the following issue:

- The consumer key or secret isn't correct. You need to register your LMS on the site, and you will be given the correct values

  • On Monday of this week Microsoft released version 1.8.3 of their Classroom Notebook it fixed it for the following versions of their OneNote product:  version 16.0.7726.1042 (Windows 7) and 16.0.8229.2073 (Windows 10)
  • Versions of OneNote that the Classroom Notebook is still broken on for our production Canvas environment: version (Windows 10) and version 1707 (Build 8326.2107) from Office 365 Pro
  • The log files don't reveal anything because the area where the error message appears on the screen, appears normal in the log files.

  • With that said while it doesn't work on our production instance of Canvas, it does work on our Test instance of Canvas.  We have tried the following:
    • creating a new LTI key
    • using our test LTI key on production

  • We currently have the keys setup on subaccounts.
  • We have an open ticket with Canvas and Microsoft.  The ticket was opened with Microsoft and Canvas on September 1.  There is still no resolution.   Today Microsoft elevated the ticket to their System Engineers. 
  • We had a similar issue occur for one faculty member on 7/24/17.  It worked for all of her colleagues and our department, but stopped working for her on 7/24/17.

Resources we have looked to:

Class Notebook add-in for OneNote instructions - OneNote 

Troubleshoot Class Notebook - Office Support 

Class Notebook Add-in stopped working - Office Support 

Resources we were looking to which Microsoft told us do not use:

They told us OneNote is a separate product than the OneNote Classroom Notebook ribbon.  If you update OneNote to try and resolve sync issues with the OneNote Classroom Notebook ribbon, that it may break the ribbon further.

Fix issues when you can't sync OneNote - OneNote 

If anyone else knows or can provide additional information please feel free to share.



Community Champion

30mins Skype with Microsoft this evening to show them the problem. Detailed review including looking at log files, connecting/reconnecting with Canvas and deleting and reinstalling plugin etc.

Noticeable issues are that once the error message appears ( see above) and you then try to disconnect, all the menu items disappear including Help:



Unfortunately, not yet able to test on our beta environment as SSO not updated on this. This will be the next step. 

In the meantime, Microsoft going to contact Canvas

IT Team inform me that there is a known issue with Azure SSO and the beta test environment. Still no solution - and

Community Champion

Good news.... from Microsoft today:

Hello, Gideon, Our engineering and development team have notified me that a fix for your issue is in the process and should be implemented by the end of next week. If you are still having this issue after the fix has been implemented please let me know and I will notify our team. Thank you for your participation and patience with us with working through this process.

Will let people know when this has been added and sorted