cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lacey_eder
Community Member

Courses on homepage and discussion boards won't load for my classes

Jump to solution

When I log on to Canvas to submit assignments, I am unable to load my courses from the main page. They just are stuck in "loading." I have to click on "Courses" on the sidebar to access anything. Then, I can't load discussion board pages. I have to go to my mobile app to be able to see any posts and replies, as well as reply myself. All I can seem to do is do quizzes. Umm, that does not work for me. How do I fix this?

I had been out of town when I noticed the problem, figured it was the internet speed, but once I got home, it's still happening.

I am using Google Chrome browser version 76.0.3809.132 and it's up-to-date. I also saw nowhere to actually report a problem so here I am, rather annoyed that I just can't reach out directly to Support themselves. I have assignments I need to turn in so I can't wait around hoping someone sees this.

1 Solution

Accepted Solutions

Hi  @lacey_eder , that is a problem! If I am correct, your institution is UT Arlington.  If so this website has contact information for Canvas Support, Canvas Students - The University of Texas at Arlington.  A little down the page there is a number you can call.  

Hope this helps!

View solution in original post

6 Replies
ericwerth
Community Coach
Community Coach

Hi  @lacey_eder and welcome to the Community.  Have you tried logging in again recently?  I see here Instructure Status that a few days ago some users were experiencing issues but that now all systems are operating normally.  Also, have you tried in another browser like Firefox?  Sometime even with browsers like Chrome and Firefox something works briefly in one and not another, particularly when the browsers update security protocols.  

What options exist in reaching out to Support depends on the institution itself.  Some have options for directly reaching Canvas Support and others go through institutional personnel first.  The options at your institution should be listed in the help menu (see How do I get help with Canvas as a student?) but hopefully in this situation the problem has resolved itself or switching to a different browser fixes the problem.

Best wishes!

I’ve tried all of that and I’m still having issues.

I also don’t have options in my help menu. I click help and it takes me directly to where I can post in the forums.

Get Outlook for iOS<https://aka.ms/o0ukef>

Hi  @lacey_eder .  Fortunately I am not experiencing this issue but unfortunately it means I don't have much way to test what could work as a fix.  I did hear from one person who said they saw something similar, but that with the browser Microsoft Edge it worked.  Not sure if this is something you could try or if it was just a fluke Edge worked for this individual.  I definitely would contact Canvas Support if you have not already done so (see How do I get help with Canvas as a student?). If you do contact Support or have already, I would be interested in knowing what they said!

I have no way to contact support is my other problem lol. I click the help menu and it takes me directly to the forums.

Get Outlook for iOS<https://aka.ms/o0ukef>

Hi  @lacey_eder , that is a problem! If I am correct, your institution is UT Arlington.  If so this website has contact information for Canvas Support, Canvas Students - The University of Texas at Arlington.  A little down the page there is a number you can call.  

Hope this helps!

View solution in original post

 @lacey_eder ‌, when a student at UT Arlington clicks on the Help link in Canvas, this is what displays (please note I've redacted the telephone number from the screenshot as it is specific to your school):
322834_UT Arlington Support for Students.png

If this is not consistent with what you see when you click on Help, please use the school contact information Eric provided to ask about this as well.