cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
glparker
Community Champion

Did the Rich Content Editor change how videos are displayed recently?

Here is the issue in detail.   Ever since we have had Canvas we have been linking videos in the Rich Content Editor using this process
- Upload the videos to files,
- then in Edit mode on the page or assignment we click on the Insert File option on the right, find the video file in the course documents and click it to hyperlink it to the text we have highlighted in the RCE.

Upon Saving the page or assignment, the video would be linked to the text for download and it would also embed on the page with a thumbnail and a play button to view it there.

This is now not happening. Now it only is linked to the text for download. Pages created previously are working with the embedded video, but any pages we have created today do not.

Did this behavior change recently?   Was it documented somewhere that I missed?

7 Replies
DaleDrees
Community Champion

Hi  @glparker ​, I just went into a course and uploaded a stand alone mp4 file into the files, then created a new page and got the link and the preview window.

glparker
Community Champion

Interesting.   I wonder, can you look at your Feature Options?   Do you have the Side Bar option turned on?

2016-08-12%20at%202.39%20PM.png

glparker
Community Champion

Yeah, i confirmed on Beta, if I have the Sidebar option enabled, Canvas doesn't render the preview.   If I disable the sidebar Feature Option, the Preview comes back when I add the video.  

2016-08-12%20at%202.53%20PM.png

2016-08-12%20at%202.54%20PM.png

I guess I'll disable that option, and file this as a bug with Canvas.

DaleDrees
Community Champion

That's interesting  @glparker ​, we don't have the sidebar option even listed in feature options.

I don't have the option available either and my videos also don't render. The only workaround I can find at the moment is to ignore the video I uploaded to Files and instead use the Record/Upload Media option in the Rich Content Editor (see below). To also add a download link, inserting from Files in the Rich Content Editor is still required.

Video issue.jpg

kona
Community Coach
Community Coach

 @glparker , are you still having this problem or has it been resolved?

chofer
Community Coach
Community Coach

Hi  @glparker ​...

Checking in with you again.  Are you still experiencing this issue?  Or, can one of the above responses be marked as "Correct" (which you can do at any time)?  For now, I am going to mark this question as "Assumed Answered" because there hasn't been any new activity since September 26th ( @kona ​' posting).  That won't prevent you or others from adding additional comments or question below, however.  Thanks Glen.