Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Member

Google Doc integration major problem

I embedded a Google Doc in an assignment, but my students cannot access it. They get some kind of log-in request, but many of them have the authorization fail. I thought CANVAS had full Google integration. Does anyone have any ideas?

9 Replies
Community Coach
Community Coach

 @seisner , do all of the students have their Google accounts connected with Canvas? Make sure of this first - - and then have them follow these directions - How do I submit a cloud assignment with Google Drive? 

Hope this helps!

Community Contributor

Hello  @seisner ,

You mentioned it was "embedded." Are you referring to the "Publish to Web" option in different Google files where you can get some code to put a document inside of a Rich Content Editor area? (Assignments, Pages, etc)

If you have a Google Apps for Education domain (I don't think particular setting is available in regular Gmail):

You may want to go to the Publish to Web settings in the file in question (File->Publish to Web) and make sure under "Published content & settings" where it says "Require viewers to sign in with their ___ account" is unchecked.

If they're just clicking a link to get to the assignment, you may want to check that the sharing settings on the document are set to "anyone with the link." (See: Share files from Google Drive)

Hope that helps!

Community Coach
Community Coach

Hi  @seisner ~ A few weeks ago,  @kona and  @awolfe both replied to your question. Did either of those suggestions help you arrive at a solution? If so, let the Canvas Community know! If not, could you share more about what your students are experiencing? That way, we can continue to help troubleshoot. Looking forward to hearing from you! Smiley Happy

Community Participant

Hi all,

I have experienced similar issues when trying to use the Google Drive LTI with both the course in which I am enrolled as a student and the course in which I am the instructor of record.

What worked in both cases was to use an incognito browser. I am typically logged into Chrome with my Google account, which then overrides my in-browser institutional affiliation. Using a different browser also worked.

Many of the students in my course were not able to get the LTI (and subsequently access to the documents) to work, so I no longer use it.

Community Member

Hi All,

I have found that if authorization fails when connecting to Google LTI, it's because the user is already signed in with a non-domain, or personal, gmail account.  I have students and teachers simply log out and then try to connect to the Google LTI again and it works.  

Hope this answers the original question!

Community Coach
Community Coach

 @seisner ,

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.



Community Member

Personally, switching to a different browser (chrome in this case- I was using firefox) helped with this. I tried everything else from clearing cookies to logging all accounts out.

Community Advocate
Community Advocate

If they are using Google Chrome, it's possible they need to do the following:


Chrome - Preferences - Advanced - Site Settings - Cookies - 

Disable "Block 3rd-party cookies" and Allow: Add (you have to use the brackets)  [*.] 

Hope that helps!  

Community Member

Hello everyone. recommend the best templating service. Free google slides templates -