Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Member

Google Drive Authorization Failed

Jump to solution

I'm trying to access my google drive but everytime I click on it, it say "Authorize".  When I click on "Authorize" I repeatedly get a message that says "Authorization failed. Please click "Authorize" to try again.

Log In

You need to authorize this integration in order to use it.

Please sign in to your Google account and authorize this integration."

I've tried clearing browsing history, disabling cache, clearing cookies (sorry i dont' know if that's the correct terminology but I've done it all).  Nothing seems to be working.  HELP!google drive authorization

35 Replies

Thanks for marking it as "Assumed Answered".  All is well.  I posted the solution in the comments above.

We hadn't had an issue with this for a while (several months) than last week one of our teachers experienced this problem with one of her students. Is there a fix we can try on our end or does this have to go through Canvas support? Thanks.

Hi Jeremy.  It seems like they've been having some issues with Google in the last few months.  Have you tried calling support?

New Member

Personally, switching to a different browser (chrome in this case- I was using firefox) helped with this. I tried everything else from clearing cookies to logging all accounts out.

New Member

I see this has been an ongoing issue for awhile.  I notice this is marked as "assumed answered", but I don't really see an answer except that for one school Canvas support got it figured out.  I'm working with Canvas Support, and they have not yet figured out the issue, and it sounds like it's pretty much the exact same issue that was mentioned here - well, two issues actually; one is the "authorization failed, please click to authorize" message, and the other is the endlessly spinning wheel for Google Cloud Assignments.  If someone knows what the solution was, please post it!

Community Champion

Hi  @aalthauscre ‌, I dread Google integration issues, they're so hard to pin down. With the spinning wheel issue, that seemed to be caused by using an older browser version. I'd check some students activity logs and if they were using an older browser version, that's probably what was going on. Our usual steps, which Support may have recommended already:

   Verify that you're using a currently supported browser. --> if not, update and try accessing the assignment again


  1. Navigate to your Canvas settings and delete Google Drive from Registered Services and from Approved Integrations
  2. Log out of Canvas
  3. Navigate to:
  4. Under Third-Party apps with account access, click on Google Drive LTI by Canvas
  5. Hit the “Remove Access” button
  6. Click your Google initial in the corner of the screen to sign out of Google
  7. Close all your browser windows and relaunch
  8. Log back into Google with your district credentials
  9. Log back into Canvas and reauthorize your Google Drive 

I was just stuck in this endless circle with Chrome on one particular laptop and couldn't find the way out of Authorization Failed.  Thankfully with a fantastic call into customer support, we tried one last thing and discovered that 3rd party Cookies was disabled in Chrome (and it wasn't particularly easy to find either!).

Chrome - Preferences - Advanced - Site Settings - Cookies - 

Disable "Block 3rd-party cookies" and Allow: Add (you have to use the brackets)  [*.] 

Hope that helps!  Shout out to Taylor in L1 Support!!

Community Champion

Any luck with "you need permission" messages for Google Drive External tool assignments?  I know what you all mean about the "spinning wheel" and authorization, but this new problem has us stumped.

Hi Lisa,

I think we have experienced this as well (if I understand what you are saying). If your course is copied from a previous course, the teacher in the course has to click on the assignment before it is visible to the students. I believe Canvas doesn't make a copy of the Google Assignment until the teacher clicks on it and makes a "class copy" first. We've also found that changes to that "class copy" do not carry over to the original Google Doc. 


Community Champion

We are finding that Google LTI imported assignments are working for all students except 1-2, so I don't think that's the issue.