cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
brian_schmidt
New Member

Has anyone been having problems re-uploading submissions back into SpeedGrader?

I have been trying to re-upload submissions into SpeedGrader but keep receiving the following error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache Server at csn.instructure.com Port 80

13 Replies
jadams31
New Member

I too have had this problem.  I have used Canvas for a few year, but only with face-to-face courses.  I am finding that Canvas is 100 % inadequate for running a course online...it fails at every second thing I try.

Students can upload, great.   But try marking up a PDF, and the doc jumps all over the place, it was impossible to grade efficiently.  I need to write on the tests to demonstrate the math properly...text comments don't do the same job.

Then, I could download all of the tests and graded them using Xodo (brilliant free app for pc).  But tried uploading them exactly as the tutorial says, and I get the same error you do.  I wonder if Blackboard users have as many issues?

I was able to upload tonight, no problems.  Not sure why it took 2 weeks to fix, but at least it is fixed!  Hopefully it is working for everyone else, as this cuts out a lot of time uploading!

0 Kudos
bossim1
Community Member

One of the instructors I support has encountered the same error message while attempting to re-upload graded student submissions in a zip file. Any word from Instructure support about what could be causing the error? Thank you!

0 Kudos
cdatko
Community Participant

We have the same issue. I'm escalating it in our case dashboard right now... Fingers crossed this gets resolved soon! 

Was there any update to this? I have an instructor that is experiencing the same issue.

0 Kudos
ellen_peters
Community Participant

We experienced the same issue and I reported it to Instructure. It is a known issue and they are working on it. It seems to happen for large files (in our case 865 MB), that take longer than 1 minute to upload. Workaround until it is fixed: make smaller ZIP Files around 50MB that will be uploaded in less than 1 minute.

cdatko
Community Participant

Thanks, Ellen! We've been recommending this as well -- seems to do the trick! 

0 Kudos

Hi James,

Thanks for getting back to me. Do you have a solution for the issue?

Thanks

Roberto

0 Kudos
dong_timothy
New Member

Thanks Ellen for this workaround and it worked for me.  I tried uploading a 109MB's worth of files in a zip file (took longer than 1 min to upload) and this gave me the error everyone here has been experiencing.  But then breaking it up into smaller batches (I did 5 batches of 20MB) worked!  Also: The person on the Canvas help line (via phone) told me that a Port 80 error means that I should restart my router.  Tried that but it did not help resolve my issue.  But Ellen's workaround worked very well.

0 Kudos
ranitori
New Member

Hi. I'm having the same issue, and splitting it up into smaller zip files has not solved it. For example, I tried with a 7Mb file. Any suggestions, other than uploading each student file separately (ugh!)? Thanks.

0 Kudos

Hi. I'm still having this issue. Any other suggestions? Thanks

0 Kudos
mark_kerfoot
Community Participant

I am experiencing the exact same error on 8/26.

Canvas folks, can you please fix this?

0 Kudos

Okay, the work around of dividing the files into smaller batches of zip files worked.

0 Kudos