cancel
Showing results for 
Search instead for 
Did you mean: 
eicherls
Community Member

Hidden, available with a link

Jump to solution

HI. I have two documents in my modules that have blue clouds instead of green. When you hover over them, they say, " Hidden, available with link". Here is what they look like (first and third below)

98356_pastedImage_1.png

I can't get them to go away. I've tried publish, deleting and re-uploading the documents, etc. How do I fix this?

1 Solution

Accepted Solutions
Robbie_Grant
Community Coach
Community Coach

 @eicherls ​,

I would recommend going into your Files area and checking the restriction properties that have been set on these files.  In Files, if you click on the cloud icon, you should see three options: Publish, Unpublish, Restrict Access:

How do I restrict files and folders to students in Canvas?

Robbie

View solution in original post

2 Replies
Robbie_Grant
Community Coach
Community Coach

 @eicherls ​,

I would recommend going into your Files area and checking the restriction properties that have been set on these files.  In Files, if you click on the cloud icon, you should see three options: Publish, Unpublish, Restrict Access:

How do I restrict files and folders to students in Canvas?

Robbie

View solution in original post

Hi Robbie, thanks for the advice... but when I select "Publish" then "Update" the permissions on the file that's hidden from students, this has no effect -- the file is still in the "Hidden.  Available with a link" state. 

I *suspect* the problem may be that I had uploaded the file into a folder (called "Other") which was created automagically (by some highly-privileged script) when the course was created -- and this folder may have some special default permissions which I'm unable to see or edit. 

Anyway... my workaround is to create a new folder, then upload a new copy of the file, and it's my lucky day: this new file isn't hidden!