Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant

How come I do not have the option to enable auto-open for inline preview in Rich Content Editor?

Jump to solution

I just read the article on how to enable to auto-open for inline preview but I simply do not have that option.  Is there a reason why?  I have included a screen shot so that you can see. Currently with the new interface, students can not see the pdf without downloading it.

Screen Shot 2015-09-09 at 2.46.48 PM.png

18 Replies
Community Champion

Although this has been answered, I thought I would share my experience.

I had (and am still having) trouble with Canvas recognizing the MIME type of a file if I uploaded through Firefox, but when I uploaded through Chrome it was fine. I had reported this to Canvas as a bug, but it was right after one of their every-three-week updates and then it worked on another machine, so I thought it was fixed. But since then, I still experience the problem, including the machine that originally worked. I stopped worrying about it and just made sure that I upload files using Chrome.

Then it recognizes them as PDF and you can do the inline preview. By the way, in the file manager, you can see whether the inline preview will work or not.


The top one has the Acrobat logo and was drag/drop from Windows explorer into Chrome less than a minute  after the bottom one which was drag/drop from Windows explorer into Firefox. You can see the bottom one doesn't have the Acrobat logo and it is not recognized as as a PDF and will not allow the inline previews. The top one with the logo will work with inline previews.

For what it's worth, I restarted Firefox in safe mode with all plugins disabled and the result was the same -- it does not recognize files as PDF. Also, choosing the Upload button vs dragging and dropping has no effect either. But it works as intended in Chrome.

Finally, you don't have to delete the files to get them to be recognized and deleting will cause any existing links to them to be broken. If you upload and replace the existing file using Chrome, then it becomes recognized as a PDF.

Again, this is just my experience and may not be your issue at all.

Community Champion

 @James ​ what you described about Firefox sounded familiar to me. We adopted new Files early on and then had a few Firefox users report the same difficulty with PDF uploads seemingly not recognized as preview-eligible, and with a blank icon rather than a PDF icon.  A Canvas Support engineer recommended this fix:

What to do if you can't download or save files | Firefox Help

Even though that solution is described as a fix to downloading, it also resolves an intermittent problem which a Firefox browser can develop: failing to send the "application/pdf" MIME type along with an upload.  (There's a different version of the same fix here.)

Community Champion

 @RobDitto ​,

It will only let me Like and mark your response as Helpful once each, but I would give you more if I could.

Removing the MimeTypes.rdf file as described fixed the problem with PDFs in Firefox.

When it recreated my MimeTypes.rdf file, it went from 17kb down to 4kb, so who knows what else was messed up in there.

Thank you, thank you, thank you.

Community Participant


I second James' response about giving multiple thumbs up to this reply. I'm running an older version of Firefox because of time-consuming-OS-upgrade-issues and sure enough the mimetypes.rdf file deletion did the trick.

I ESPECIALLY appreciated your explanation about why this worked because the fix being all about downloading did make me doubt whether I was in the right place until I read your post again.

The best part about your discussion here is that it highlights a big clue about this problem...the file appears without the Adobe Acrobat image in the file icon--Danger, Danger Will Robinson.

Thank you very much gentlemen, you just helped me fix something that was starting to get quite frustrating.

Best wishes,


Community Participant

I have the same problem and tried the solutions, but it is annoying that it does not help. I succeeded to preview one file, but the second one is still not visible. Last time working with canvas, all was fine, but today it is not working. More options to fix this?

 @zwenneke  Welcome to the Canvas Community! Are you a student? If so, you might have to ask your instructor to re-upload the file—and it would probably help matters along if you could submit a support ticket as well to bring the absence of a preview icon to our support team's attention ( ).

Community Participant

No, I am not a student, and I have exactly the same problem as the TS. 

What did I try? 

- renew browser

- delete file and upload again (the file is mentioned in the list as a pdf-file

-delete link and make new link

-close canvas and log in 

In the end, after trying for 3 hours I succeeded to upload the second file. 20 to go, so that is not an option timewise, so still looking for the solution, because it was a matter of luck how I did it now. 

One month ago, all seem to work fine, I did not see this problem. 

 @zwenneke ‌, thanks for elaborating. If the preview icon is not appearing upon save when you upload a file using the Content Selector, please initiate a support ticket; it sounds like the Upload a new file option is no longer performing as designed (How do I get help with Canvas as an instructor?‌)

It's May 2021 and still no real solution. 🙄