Community

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
williamsj3
New Member

How do I fix a Loading Failed Message?

So I am running the latest release of Canvas on Ubuntu 14.04 LTS and I notice inside of courses that it says "Loading Failed".  This is the Links section where it lets you link to other content within the course.  It shows it under Pages, Assignments, Quizzes, Announcements, Discussions, and Modules.  The section called "Course Navigation" shows find and I am able to click anything below it and insert it into an assignment. 

252463_2017-09-20_13-26-04.jpg

5 Replies
rconroy
Instructure
Instructure

Hi again,  @williamsj3 ‌! 

I've also shared this with the Canvas Dev group and updated some tags for more exposure. Glad you're sharing these questions with us! I'm looking forward to seeing some development on them!

chofer
Community Coach
Community Coach

Hi there,  @williamsj3 ...

I thought that I would check in with you on this topic.  (Thanks to Deactivated user‌ for sharing this question with the https://community.canvaslms.com/groups/canvas-developers?sr=search&searchId=6bb21c9c-8efa-4f60-83cd-...‌ group here in the Canvas Community!)  It appears that you may have stumped the Community with your question.  Have you been able to come up with any solutions on your own since you first posted this question on September 20th?  If so, would you mind sharing what you've found back here in this thread?  Or, if you are still looking for some help with this question, please let us know by posting a message below so that members of the Community might be able to help troubleshoot this with you.  For now, I'm going to mark your question as "Assumed Answered"...not because an answer has been found...but because there hasn't been any activity in this topic for two months.  This won't prevent you or others from posting additional questions/comments below which are related to this topic, however.  I hope that's alright with you, Michael.  Looking forward to hearing back from you soon!

Hello Chris,

I am new to canvas and managed to launch the lms in production mode a few months back. However, recently came across this "Loading failed" error as shown in screenshot from "@Michael". Could you guys help me out?

Running on Ubuntu 16.04.3 LTS.

Thank you all,

Raj.

chofer
Community Coach
Community Coach

Hi  @srdurai ...

That error message is not something I'd be able to help troubleshoot as I'm not familiar with the back-end code of Canvas, and I was only checking in with Michael.  I would recommend that you reach out to Canvas Support and log a ticket with them to see if they might be able to help you further.  You can do that by clicking on the "Help" icon on the left side of your Canvas environment, and then you should see some options there to contact Support.  Hope this helps, Raj.

jcoehoorn
New Member

I believe this issue has the same cause:

https://community.canvaslms.com/thread/15417-edit-page-loading-failedno-results

The fix involved some blocked javascript.

You may also see problems now related to a change to a new API for the Rich Content Editor, as seen here:

https://community.canvaslms.com/thread/34368-javascript-404-errors-for-unusual-url-routes-when-editi...