scott_groomes
Community Member

How to have Zoom appear by default on all course menus

Jump to solution

We installed Zoom LTI Pro in our Canvas instance and the default setting for the Zoom LTI  for every course is that it is hidden and has to be enabled via settings-navigation menu. Is there a way to make Zoom appear by default on the course menu for all courses including existing courses without having to "unhide/enable" it for every course?  

1 Solution
jwadec
Community Contributor

Hey, Scott!

Yes; there are two options in which you can make Zoom show for everyone. 

Option 1

Reinstall the tool and when you copy/paste the XML for the tool provider, you'll want to change this line:

<lticm:options name="course_navigation"> <lticm:property name="default">disabled</lticm:property>

Change it to this: 

<lticm:options name="course_navigation"> <lticm:property name="default">enabled</lticm:property>

Option 2

Use a program like Postman to make an API call that will update the default view. You have to go the API route since this has not been added to the user interface. 

External Tools - Canvas LMS REST API Documentation provides some details on how you can do this if you have cURL installed. 

View solution in original post

7 Replies
jwadec
Community Contributor

Hey, Scott!

Yes; there are two options in which you can make Zoom show for everyone. 

Option 1

Reinstall the tool and when you copy/paste the XML for the tool provider, you'll want to change this line:

<lticm:options name="course_navigation"> <lticm:property name="default">disabled</lticm:property>

Change it to this: 

<lticm:options name="course_navigation"> <lticm:property name="default">enabled</lticm:property>

Option 2

Use a program like Postman to make an API call that will update the default view. You have to go the API route since this has not been added to the user interface. 

External Tools - Canvas LMS REST API Documentation provides some details on how you can do this if you have cURL installed. 

bickley_tl
Community Participant

Hi Justin,

In regards to the question asked by Scott we have both Zoom and Pro installed. Zoom is in our course navigation which we would like to disable now and replace it with the Zoom Pro.

I have tried changing the scope settings on Pro but nothing changes. I was able to disable to original Zoom course navigation.

I am not familiar with API calls, if this causing it not to update. Is there somewhere I can learn about API calls?

Or anyone I could contact?

Thank you, Terry

0 Kudos

Thanks!  Option 1 worked for me. Thank you for the info.

0 Kudos
joe_fahs
Community Participant

Hi @jwadec 

Thank you for your post on enabling Zoom in navigation by default. Rather than re-installing the Zoom LTI and applying Option 1, we are trying to display Zoom in all courses using an API call. 

I tried this command using Terminal for macOS replacing toolid and accesstoken with the actual values. 

curl -X PUT "https://enc.instructure.com/api/v1/accounts/1/external_tools/toolid" -H  "Authorization: Bearer accesstoken" -F "course_navigation[default]=enabled”

and the command appeared to have worked with this string as part of the result

"course_navigation":{"default":"enabled",

However, it appeared to have no effect. That is Zoom is not automatically enabled in navigation. Have you are anyone else tried an API call to put Zoom in the menu bar for all courses?

Thank you, Joe

 

 

jwadec
Community Contributor

@joe_fahs 

I believe you'll want to send course_navigation[enabled]=true as the variable to that endpoint.

0 Kudos
joe_fahs
Community Participant

Thanks, @jwadec 

I tried that parameter and the command worked but the results are the same as when I apply course_navigation[default]=enabled. Zoom stays hidden in navigation. 

Joe

0 Kudos
joe_fahs
Community Participant

Hi @jwadec 

Sorry for the confusion. Both commands course_navigation[enabled]=true and course_navigation[default]=true did work and displayed Zoom in course navigation. I did not sample enough courses and realized that some instructors already removed Zoom from course navigation on their own. 

Thanks, again, for your help!

Joe