How to stop error "Grading Category missing" when syncing to PTP?

Jump to solution
Community Explorer

I am having trouble syncing my grades from Canvas to Powerteacher Pro (first year using PTP, had no issues with regular PS). When I go to sync a grade, I'm getting this error: "Grading Category missing for assignment." However, the assignment has the category "Quiz" and the category "Quiz" exists on my PTP written the exact same way, same weights, etc. I can't figure out what isn't working. I searched the guides and previous questions and couldn't find any answers there either. I've tried it with other classes and other assignments. I've tried deleting and recreating the categories on both PTP. Nothing seems to be fixing it. Any suggestions would be appreciated.


A lot of people have been finding me and messaging me to see how to fix this. 

You need to go to the assignments page on your canvas class. Click the three dots in the upper right corner and choose “Import Assignment Groups.” Canvas will pull your categories from PowerSchool and pop them into Canvas. You’ll need to move all of your existing assignments/quizzes/etc into the new categories and delete the old. The new ones will have the little PowerSchool sync symbol.


1 Solution

Make sure you are using grade categories that you IMPORTED from PTP. Just setting up similarly named categories won’t work. This solved my issues.

View solution in original post