cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
javierht
New Member

I can not assign an assignment to an specific group in a course

Jump to solution

I am trying to assign an assignment to a course group so as to only the members of the assigned group can view the assignment in the course. The other groups in the course should not be able to view that assignment. I have read the following link: https://community.canvaslms.com/docs/DOC-2652, and it seems to match what I am looking for. However, when I try to “assign to Group”, as described in the documentation, no groups are showed in the list. Only course sections and students are displayed. Even when I try to enter the group name, no results are found. As a result, I can not make available the assignment only to the desired group.

I have even tried to assign the  assignment to an specific section but after saving the changes and editing again a “Everyone else” section has been automatically added. The same happens when I try to assign the assignment to an specific user.

Am I doing anything wrong? Is there any bugs in the Canvas functionality of assigning to an specific group/section/student in the course?.

I do not know if there are any other alternatives to make available an assignment only to a course group, not to all of them.

The following screenshots try to explain what I am saying. The purpose is that only the students in the group called "Group Set 1 - Group 1" can view the assignment.

First, I create three Group Sets in the course: Group Set 1, Group Set 2 and Group Set 3.

group_sets.png

Secondly, I create the assignment.

I select the Group Set 1 as the group Assignment.

group_assignment.png

This is where I try to assign the assignment for an specific group in the Group Set 1. However, only sections and students are displayed:

assign.png

I try to enter manually the group name but no results are showed:

assign_no_results.png

This is what happens when I try to assign for a course sections:

assign_section.png

And after saving and editing again the "Everyone else" has been added automatically.

assign_section_saved.png

As a result, every group in the course can view the assignments that I create. All suggestions to try to solve this problem are welcome.

1 Solution

I confirm that it was an issue related to my particular installation status. We changed to a installation on the cloud and the problem disappeared.

View solution in original post

12 Replies
Stef_retired
Community Team
Community Team

 @javierht ​, from your screenshots, it appears that you've missed an essential step in the group setup process. Group sets are essentially containers for groups (meaning you might want to have one group set for one assignment and a different group set for another one). After you've created group sets, you still have to create groups within those group sets--and when you create the groups, you will still need to assign students to those groups.

These are the relevant guides for creating group sets, groups, and assigning students to those groups:

525 - Groups: Creation & Management on Vimeo (video)

What are Student Groups?

How do I manually create groups in a group set?

How do I automatically create groups in a group set?

How do I automatically assign students to groups?

How do I create self sign-up groups? (I put this here for completeness' sake, but it's probably not relevant in this case)

How do I assign an assignment to a course group?

Try creating the groups and assigning students to them according to the method you've chosen from the guides above. Then go through the "Assign to Group" process again, and let us know what happens!

Stefanie, thanks for your reply and the links.

As you can see from the first screenshot of my question, I created three group sets in the course: Group Set 1, Group Set 2 and Group Set 3. Then, within each group set, I manually created two groups. For instance, Group Set 1 had two groups: "Group Set 1 - Group 1" and "Group Set 2 - Group 2". That is, I had six groups in total. Finally, I manually assigned two students to each group.

As you suggest, I have also created a fourth group set, "Group Set 4", containing only a group called "Group Set 4 - Group 1". I have assigned two students to this group. After that, I have gone through the "Assign to Group" process again and I have the same problem: no groups appear and no results are found when I manually enter the Group name in the "Assign".

These are the screenshots of the creation process:

The creation of the "Group Set 4":

create_group_set_4.png

Add the group "Group Set 4 - Group 1" to the group set:

create_group_set_4_group_1.png

The group after assigning two students: student13 and student 14.

group_set_4_group_1_students.png

Thanks again for your quick answer.

Yes,  @javierht , I see that now; sorry I missed it on the first scan of the screenshots. Unfortunately, I was not able to replicate it. I just created a new group assignment, my existing groups (not just sections) displayed in the Assign To dropdown, and I was able to select only those groups to which I wanted to assign it; I even received a warning message in the Save process: "Not all sections will be assigned this item. | Would you like to go back to include:..." with the message going on to list the sections I had not included. After proceeding through the warning message and saving the assignment, I then went back to use the Differentiated Assignments feature to add a single student to the Assign To field; that, too, was successful.

So the only advice I have left for you is to submit a help ticket. Click on Help in the lower left of your screen, and select Report a Problem from the menu. To help Canvas Support troubleshoot this, and to save you a lot of time, you can provide a link to this Community discussion in the description field so they will be able to see your excellent screenshots.

Sorry I couldn't be of more help.

Stefanie, thanks for your answer again. I think it could be a bug or a version related problem, because I can not find the help icon in the lower left of my screen. The Canvas installation that I am using is installed in our own server. I do not know if that could have something to do with that too, in terms of some kind of limitations to the use of Canvas or other restrictions. I created a teaching account  at  https://canvas.instructure.com and everything worked as should be expected. I can also see the help icon that you mentioned.

kona
Community Coach
Community Coach

Yep, my bet is that the issue is related to it being run on your own server. Glad you were able to make a free account and get it to work!

Stef_retired
Community Team
Community Team

 @javierht ​, that's helpful information. As you know, for most of us, Canvas does not have versions, as we are in the cloud, so "versions" is not the first thing we think of--but in your case, because you are working from a self-hosted instance, it is entirely possible that you are not able to assign to groups because of the status of your particular installation and when and how it was last updated. I am glad to know that you were able to follow the steps outlined above in the Free for Teachers account and experienced no difficulties. My only remaining recommendation would be that you bring this to the attention of the people responsible for maintaining your instance of Canvas so that they can perform the necessary updates.

Thanks a lot. Our system administrator is going to try to update our Canvas instance. I will give you some feedback as soon as the updating process finishes and I can then check whether it works.

Thank you,  @javierht ​. For now, I've marked this question as "assumed answered," but it remains open for participation, so please keep us updated!

I confirm that it was an issue related to my particular installation status. We changed to a installation on the cloud and the problem disappeared.

pswaisland
New Member

Hi, I am having a similar issue, however I have created a group within the group set, and ive assigned it to that group but i am getting this warning when i try to save the ssegnment:

217800_ScreenShot of warning.png

After clicking 'continue' nothing happens... it goes back to assignment edit screen as though i never pushed save. if i close ou of edit mode, and re-enter, it changes to "assign to Everyone"

Sorry if i missed the answer to this already in the thread.

Phil

I am having the same problem. I have used this process for several semester and it has worked but suddenly it has failed exactly as Javier describes. I am using Canvas cloud-hosted.

I created seven groups with 5 or six students each:

220305_Untitled.png

Using the procedure shown in this thread I managed to assign the following assignment to the Group "Midterm Online Game 2." I clicked save and the group was assigned.

220306_Screenshot2.png

But after that the process always fails. I edit any assignment and assign a group, then I click SAVE and see this warning:

220319_Screenshot3.png

I click CONTINUE and nothing nothing happens. The settings are never saved.

0 Kudos

I found a workaround.

The problem seems to be that I used this strategy in a previous semester. When I copied the course into the new semester that group didn't exist. The assignment copied into the new semester assigned to no one.

Apparently this puts a barrier to assigning to a student group. You can't assign a group until the assignment has been temporarily assigned to "everyone."

Here is my new workflow:

1) Edit the assignment and assign it to "everyone".

2) Save the assignment.

3) Edit the assignment again and delete "everyone."

4) Finally assign it to the desired group and click save.

Only then can you click past the warning message.