Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Member

Immersive Reader Not Showing for Students

Jump to solution

We have Immersive Reader turned on, and is available in Teacher view, but when in student view (and students) are unable to see the IR button on Pages. 

I have IR enabled and locked at the Root level, am I missing something? Or is this a Canvas Support issue?


Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Community Team
Community Team

Thanks, everyone, for your patience! This has now been resolved, and if you submitted a support case, you should have received an update directly from Canvas Support. The now-former known issue is    Immersive Reader button is hidden for Students whe... 🙂

View solution in original post

14 Replies
Community Coach
Community Coach

Good evening, @willc ...

I was unable to replicate this in my own sandbox course.  I had a page of text in my course, and I switched over to the "Student View".  I was able to see the "Immersive Reader" button at the top right corner of my screen.  You might want to contact the Canvas Help Desk staff about this one.  How do I contact Canvas Support? - Instructure Community

Community Champion

Hi @willc, this was noticed at our school too.  A chat with Canvas support both clarified and disappointed.

Answer:  Immersive Reader is not visible to students unless Pages is enabled on the course navigation menu.  I tested and that's how it works for students and in Student View too.  The student guide documentation on the feature does say to go to Pages and view the page from there, guess that was a clue. How do I use the Microsoft Immersive Reader when v... - Instructure Community ( It also works when viewing from a module.

Since most teachers hide Pages, this is disappointing to learn. 

Maybe I will write an Idea to make it available with Pages disabled on course navigation.  I wish this caveat would be added to both instructor and student documentation, it's important to know.

This is really frustrating. There is a reason I don't have the Pages link enabled--students have enough trouble staying on track without wandering through pages I am not ready for them to read yet. And why hiding Pages should disable the Immersive Reader function is beyond me. If anyone knows of a workaround, please share. Otherwise, I would certainly support a feature idea to fix the issue.

Community Team
Community Team

Thanks to everyone who has contributed to this thread. We are aware of this behavior and are working on a solution. In the meantime, if you'd like to keep informed of the progress toward resolution, please initiate a support case and request that it be associated with the engineering ticket.

Greetings @Stef_retired!

Would you happen to have the engineering case # for this issue (pretty please)?


Thank you, Stephanie and have a WONDERFUL Day!

With Warmest Regard,

Timothy S. Lampley

As a visually impaired student, this feature is a necessity to me. I hope we find a way to bypass pages issue soon. 

Community Participant

Thanks would be great to get this working, we are going to be relying on it quite heavily for our ESOL learners,

Hi wonderful @Stef_retired, is there any news on Immersive Reader being available when Pages is disabled in course nav?

I reported this and was not added to any engineering ticket, just told it only works in Pages and sent a link to how to use it.

Just in case it's not currently being fixed, I created an idea, because I know it will get archived if there is an engineering ticket for the fix.  Make-Immersive-Reader-available-when-Pages-is-disabled-in-Navigation

Thank you!

@Nancy_Webb_CCSF  Thanks for the heads-up! I archived your idea and referenced the known issue. If you'd provide me the case number for your interaction with support, I can make sure that your case is associated with the engineering ticket.