Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Member

Issues with opening Kami assignments on iPad with Canvas app/Google Authorization?

EDIT TO THE EDIT: So according to Kami support, the inability to open Kami assignments for grading is a Canvas iOS issue.  While I think Canvas is aware of it, not sure if there is any action on their part to fix it.  Apparently Canvas didn't set up authorizations for Kami/Google Drive with their update, which is now causing the issue.

The SECOND issue: having to open an assignment in Kami before a student does, is a Kami "fix" because of issues around who created the document in Kami.  So for now the workaround is that teachers have to load and open the assignment before the students.  I'm not thrilled about this and it wasn't clear if this is a temporary fix, or if this is now a step that must be included whenever creating a Kami assignment.

EDIT: It appears that Kami is aware of the situation and is working to fix it.  Workaround suggestions are greatly appreciated!


I am a high school teacher.  We are online full-time currently.

We use Canvas as our LMS and have integrated Kami for students to complete and submit assignments.

I use my iPad to grade Kami assignments with the Canvas app; until today, it has worked perfectly.

Now when I try to open student Kami assignments in the Canvas app for grading, I first get an authorization message; then when I try to authorize, I get an error message about unblocking pop-ups.  I have done this and still get the error message.

Is anyone else having this issue, and is this a Kami issue, an iPad issue, a Canvas app issue, or a Google issue?  I'm really frustrated here because the whole point of using the ipad is to make it easier to grade student work than on a laptop, and now I can't access their assignments at all.

Labels (3)
Tags (3)
13 Replies
Community Member


No issues grading other (non-Kami) assignments through Canvas app on the iPad, so I'm starting to really suspect it's a Kami issue, although iPads and Canvas Teacher were both updated recently so it could just be the perfect storm. 

I've sent screenshots and emails to Kami for help but the automated reply said they were getting hit hard with emails, so I am guessing we're not the only squeaky wheels.  Can grade just fine with Kami and through Canvas on my laptop...but it was a lot easier to comment/write using the iPad.


Community Member

Right...I've been trying everything today.  I hope that it's something that can be resolved because grading with the App is so easy!

Community Member

Well. Given I had this issue show up today. Maybe there will be resolution in a few days. Until then stop working so much?

Community Participant

I am having the same issue. The funny thing is I tried it on my Iphone in the Canvas app and it opened just fine. I have to log into my google account when I click that it pops up and has me verify my google account. So I think it is an Ipad + Canvas + Kami issue. I emailed Kami as well, but I am waiting for a response.

Community Member


Community Member

Same issue and still no reply from Kami 5 days on.

I've included screenshots here.

Assuming it is a glitch on Kami's end but possibly something with pop-ups or Google authorization could be addressed by Canvas developers?


Community Member

I too am having problems grading Kami and Google Cloud assignments with the teacher app.  Another issue I am having with Kami is with my students opening their assignment in Kami.  I have to open each and every assignment before they can access it.  According to Kami, this is because the file was shared to me by another teacher.  However, the files were not shared to me by another teacher.  I upload the files to my Google Drive and into Canvas the same way I have added every other assignment.

Community Participant

I found an easy work around. (I hear the eye roll, I hate work arounds too. Something should work the way it is designed and suppose to work). If you use the browser on the Ipad and not the app it will open and work just fine. It seems to be something with the Canvas app that is not allowing the pop up to authorize the google connections. Hope this helps for now.