cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
emily
Community Champion

Linking to Speedgrader URL

Jump to solution

Hello!

 

We are working on a project to make it easier for multiple faculty graders to find the students THEY need to grade. We are doing this by building a list of the students they need to grade, with (hopefully) clickable links directly to the assignment/student in SpeedGrader.

 

As part of this assignment, students complete a self-evaluation in Qualtrics.  From that, we can gather an automatically-generated “referring URL” that looks like this:

https://umich.instructure.com/courses/226670/gradebook/speed_grader?assignment_id=509549#%7B%22stude...

 

This is great – it’s got the course ID (226670), the assignment ID (509549) and the student ID (353174), so theoretically, we should be able to click this and go to the correct student record. However, when you go to that URL, you can see it load, “think”, then it redirects to the first student ID in the course (in this case, 353173 instead of 353174). In certain circumstances, it works (like if I paste the URL in a browser) but in most cases where I’m clicking a link (like from an email or a web page), it reverts to the first person on the list.

 

I’m looking for any kind of solution to help us make a clickable link. I know we can use a “not-Speedgrader” link (https://umich.instructure.com/courses/226670/assignments/476218/submissions/353174) but we prefer the Speedgrader interface. Is there a Speedgrader URL in a better format we can use? Is this a bug? A matter of proxies and redirects?

 

Or is there a pre-built, easy way to have students pick which teacher will grade them, and then each teacher only sees their own students on the to-do list? (Didn’t think so, but worth asking!)

Emily 

Tags (1)
0 Kudos
1 Solution
emily
Community Champion

I did get a reply on this: 

I'm not getting directed to the first student when clicking that link, I am instead being directed to the second student correctly.  Are you losing the fragment off the end of the url when getting redirected into Canvas?  We used to have some similar behavior with SpeedGrader links here in the office caused by our authentication system.  As long as you make it into Canvas with the fragment intact in the URL you should see the correct student load in SpeedGrader. 

It appears that authentication was losing the closing } off the link, especially when the email was formatted as HTML. We have now been able to get this to work, by including the concatenated URL in an email and letting the email reader turn it into a link (rather than formatting beforehand). It also works to use this URL to format a row in a Tableau report that allows you to click the link and go directly to the Speedgrader item that needs to be graded.

View solution in original post

3 Replies
kmeeusen
Community Coach
Community Coach

Hi  @emily ‌

Great question, but certainly not one I am qualified to answer. I will share this with the Canvas Developers group where the smart folks live.

Kelley

0 Kudos
emily
Community Champion

I did get a reply on this: 

I'm not getting directed to the first student when clicking that link, I am instead being directed to the second student correctly.  Are you losing the fragment off the end of the url when getting redirected into Canvas?  We used to have some similar behavior with SpeedGrader links here in the office caused by our authentication system.  As long as you make it into Canvas with the fragment intact in the URL you should see the correct student load in SpeedGrader. 

It appears that authentication was losing the closing } off the link, especially when the email was formatted as HTML. We have now been able to get this to work, by including the concatenated URL in an email and letting the email reader turn it into a link (rather than formatting beforehand). It also works to use this URL to format a row in a Tableau report that allows you to click the link and go directly to the Speedgrader item that needs to be graded.

carols
Community Member

Hi Emily

Thanks for posting this question and then the solution that you found - much appreciated.

I have a similar problem with links to Speedgrader that we automate within another web app that staff and students use. Our url format is as follows:

https://canvas.sussex.ac.uk/courses/sis_course_id:915N1_T3_19_20/gradebook/speed_grader?assignment_i...

Did you find documentation from Instructure that helped you to resolve your issue? I'm looking around to see if I can find any guidance and haven't yet managed to identify anything.

Cheers

Carol

0 Kudos