Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant

Mastery Path Issue

Hello all!

I'm trying to set up a Mastery Path starting from an introductory quiz, but I'm consistently running into the same issue. When I complete the quiz using the test student environment, no subsequent material is released. Instead, the module continues to say "Locked until [quiz] is graded" despite the mark appearing in the "Grades" section. I have checked the quiz/mastery path settings and can't seem to find anything that would prevent the release of material, but I must be missing something.

Has anyone else had this problem? Any help would be much appreciated!

Tags (2)
21 Replies
Community Coach
Community Coach


Are all of the questions on the quiz self-grading?  If there is a short answer or essay question, that would require them to be graded for the processing to occur.  With the Test Student, have you clicked the Reset Student button?  In order to clear out any previous quiz attempts and testing you've done you'll want to click Reset Student.

If it's not any of those things, perhaps you can post a screenshot of your Mastery Path settings for some of us to take a look at.

Hi Rick,

Thanks for the response! All of the questions are self-grading and I've tried resetting the test student, to no avail. Here are screenshots of the module and mastery path. Each discussion/assignment is assigned to "Mastery paths" only. I have also attached images from the student view for reference.280373_mastery path1.PNG280374_mastery path2.PNG280375_mastery path4.PNG280376_mastery path3.PNG


Do you have any other items in this course set up for mastery paths?  I ask because in your Module screen shot, the Reading Level 1 and Mastery Path Discussion both show Multiple next to them, even though they only exist in your Mastery Path settings once.  Math Reading Level 2 should show Multiple (like it does) because you have it in two different point thresholds.  I've replicated your set up and here is that difference I am talking about and what I see instead of Multiple for those two.



If you don't have have them set up in more than one Mastery Path, perhaps you've changed some things from when you originally set up the Mastery Path and for whatever reason Canvas didn't process that change.  I would try deleting the module and then creating a new one and setting things up again.  The quiz, assignments and discussion won't need to be re-created, you'll just need to add them to a new module and then set up the MP again.

Let us know if that helps or fixes the problems.  

Hey Rick,

Yes, I tried to create a similar mastery path using the same material. I've since deleted/recreated the mastery path and I'm running into similar problems. After completing the quiz, the module remains locked.

280377_mastery pathnew.PNG280378_mastery path new2.PNG

Community Coach
Community Coach

I've been pulling my hair out over this one and I'm beginning to think there is a bug.  I'm having the same issues as you now with the course I originally started playing with this in.  I even reset the course and recreated each of the items, but still it's not working like it should; but not totally like what you are seeing.  In my case it says Locked until ..... is graded" but the other content that should be locked isn't and can be accessed.

I just created a new course and am having success if I set it up correctly the first time.  I'll try to play some more with this but if you are still playing I suggest trying again with a new course and see if it works correctly there.  I'll post back if I get any further along with my testing.  

Glad I'm not the only one! I did some searching and noticed a few other people were experiencing the same problem so I think you might be right. I'll do some more testing as well- hopefully this post finds its way to the right developers at Canvas!

Community Champion

Hi luke.swabey
I agree with  @rmurchshafer  , I believe there is a bug in the Mastery Paths tool. We tried it out on our beta environment earlier this year and encountered exactly the same problem that you're seeing, with the "Locked until mastery path is processed" message appearing even after the student had completed the quiz. I logged a ticket with Instructure support and also mentioned it to our Instructure CSM, and it just went back and forth between us for a while with them suggesting various changes we could make to the settings but none of it helped. It actually became a running joke about how much I hated the Mastery Paths tool! In the end our CSM admitted that it probably is a bug and we still haven't enabled Mastery Paths on our production environment. I had actually forgotten about it until I saw your post today so I went back and tried it on our beta environment again with a new quiz and a new set of pages. The problem is still there so I don't think we'll we switching it on for our users anytime soon.
Have you logged a ticket with Instructure support yet? I don't know if they will be able to solve your problem but they might tell you if it's a known bug and if so, when it's likely to be fixed.

Community Participant

Hey Steve,

Thanks for the information! I haven't submitted a ticket with Instructure support, but I will when I get a chance.

Community Member

I'm experiencing this as well.

Any updates from others? Any result with the instructure support ticket?