Showing results for 
Show  only  | Search instead for 
Did you mean: 
Community Participant

Media Comment Tool - What breaks it?

We’re having a slew of issues with the media comment tool, across the full range of browsers and OS. The problems are not consistent, but happen steadily and regularly. We’ve tried the usual responses (update Flash, clear the cache, reboot, etc), but no luck.

The stock Canvas Support response (beyond the usual) is that it’s a local problem, which isn’t particularly helpful. And frankly, if “it’s your problem” gets said to users too much, they rightly decide that the tool isn’t worth the time, and then it’s my/Canvas problem.

So it seems there’s a few other places this could choke:

  • browser extension conflict
  • browser security setting conflict
  • firewall rule

Have you found any common issues that cause the media comment tool to choke, beyond the usual Flash update/cache stuff?

22 Replies
Community Coach
Community Coach


I do a monthly workshop for faculty on audio and video in Canvas.  I have had issues in our lab in every workshop except our last one in November.  These are all the same computers with the same build (we ghost them once a month with the same image).  In November, I had 15 faculty and not a single one had an issue.  In the past, we have had to restart computers, reset browsers, you name it and it suddenly works.  It is an amazing tool but we have found it to be finicky.  We usually let our faculty know that they need to be patient when using audio and video in general.


Robbie Grant Admin wrote:

It is an amazing tool but we have found it to be finicky. 

I would second this comment.

We've had off and on issues with it as well. Sometimes it fails to ever fully load even though we've accepted all the security prompts. Sometimes recordings fail to save properly, especially long ones. Sometimes the browsers are angry at Flash vulnerabilities and we have to jump through special hoops or recommend something other than our default browser (Chrome) temporarily. The problems are incredibly frustrating to try and reproduce as well.

It sure would be nice to have something reliable. Maybe there is something in the works by Instructure to make creating video and audio recordings better! (hint hint, contact your CSM Smiley Happy )


Also, since there is no single correct answer to your question, I am going to convert this post to a discussion. This will allow people to continue to comment but it will not indicate that any particular answer should be marked as correct.

Community Contributor


       We've been experiencing issues with the media recorder / viewer when used for comment feedback as well.  It is starting to become very problematic for our instructors.  We also noticed that when playing back media comments, whether video or audio, the player controls are cut off on the screen.  The video controls can barely be seen and accessed, but the audio can not be accessed at all. 

     While troubleshooting media play back today (controls were unavailable), I found I was having issues initializing the webcam and headset microphone when trying to record in Chrome.  The connecting screen would just keep going.  I've messed with all the settings mentioned with no luck.  I noticed that while my flash settings were open, the mic picked up the sound of my hand hitting the desk in frustration and behind the flash settings box, I saw the audio level bar pop out of the recording screen.  Once I pressed closed on the Flash settings, I was good to go.  Now when I press record audio in Chrome, I need to just make a sound and the connecting screen goes away and I'm ready to record. 

     After testing in Chrome I then went into Firefox to see if making a sound would work, but since I got it to work in Chrome, Firefox seems to go straight into Record mode with no issues.  Next time I have issues recording, I'm going to try these steps again to see if it corrects the bug again.  I'll post back if it does.

- Ryan

Community Participant

Hi Ryan,

An update from here: I'm basically holding a ticket open with Support on this, and sending reports all on that ticket as they come in. Support has asked for the usual data (username reporting the issue, OS, browser, make sure everything is updated, caches cleared, etc), and then asked for the time that the problem occurs. The plan is to go back through the logs and look for the incident and see what shows up there.

We're still getting intermittent flaky behavior. It dropped off in late December/early January, of course, while instructors were gone. It's back now, as they start grading with the tool.

One instructor found he could record with Quicktime, then upload. The upload only works every other time, but at least the video doesn't get lost when it chokes. That's a worthwhile workaround, I guess.


Community Participant

I've had a lot of trouble with this as well and Canvas support recommended submitting a new feature idea to have engineers spend more time on the connection time (and hopefully its reliability in general).

Here is the link for those who are interested:

Thanks lee_knowlton‌ for submitting the feature idea and I'm sorry it didn't get enough votes.  I use Firefox and never had a problem recording a media comment, but Chrome presented problems to instructors.  Adding our school's Canvas URL to the list of allowed Flash sites in Chrome's Advanced Settings/Content Settings/Flash helped a little, got all the way to seeing a record button but still not able to connect (little clock keeps circling).  Finally clearing the Adobe cache got it to connect and record quickly.  I also chose my microphone in the Adobe settings dialog box, changing it from Default.  Perhaps that was not necessary.

How can a student go through all this?  How can an instructor support all the students using Chrome?  It is time to replace the flash based media comment recorder.

It just spins for me. Never loads. Not a useful tool. I agree that it's [PAST] time to move away from Flash!

Community Member

Just worked through this same problem as I try out audio comments for draft feedback. I couldn't get it to work (same problems as mentioned above), but I did get it to work consecutively on several drafts before taking a break. I took in several of the solutions mentioned above, so I apologize if this is repetitive:

  1. Edited Flash settings via Chrome to "Ask" anytime a website wants to access my mic. (Chrome browsers apparently require this type of editing, according to Adobe Flash.)
  2. Edited local settings (on the computer) to include our campus's .instructure URL as an allowed website to access my mic.
  3. Refreshed SpeedGrader.
  4. Instead of just a spinning wheel of death, I got a prompt this time asking me to use the mic. Clicked "yes." (It asks every time.)
  5. Got a connecting clock. Simply making a sound on my mic (saying "testing," beatboxing into it, or just tapping it with my finger) turned that clock into a red recording button.
  6. Click the button to start recording. Click again (now a "stop square") to stop the recording.
  7. Comment played back and clicked save to post audio comment.
  8. Played back fine when I clicked on my own comment.

Hope this helps someone else navigate the problem!