cancel
Showing results for 
Search instead for 
Did you mean: 
jschofield
Community Participant

New embed images not displaying

In a current course I am building any new images (JPEG, PNG) that I embed into the course will break and not display.  Images that I have add last month are displaying fine. The issue is with any new image I had, after a few hours they break.  Is there an issue with the html code that is being used to embed from files into course content?

6 Replies
bsmaples
Community Participant

Jack,

We have seen this issue in some of our courses as well, but the image will reappear at a later time. Here is another thread related to the issue: 

https://community.canvaslms.com/thread/21091-images-embedded-in-pages-disappearreappear-at-random 

Sadly, many of us are experiencing this problem right now Smiley Sad  It is a good idea to submit an official Support Request to Canvas on this - so that Cavas is aware of the full scope of the problem. You will want to tell them what browser you are using, and maybe also copy/paste the information with the other case numbers (above). I expect that the more examples the engineers have to reference, the easier it might be to narrow down the problem (e.g. common denomenator across similar issues). You may also want to include some of the information already gathered from others. Here are some of the case numbers we have so far: #02672254, #02675969, #02687703. #02667582, #02676804, #02688690, #02690931. The idea is that Canvas will then be more aware of both the urgency and scope of this problem. Here are also just a few links to other recent conversations associated with this issue.

In case you are unfamiliar with how to submit a support request...

Once you login to your Canvas LMS, click on "Help?" from the Main Menu on the left. Then select "Report a Problem" from the 'dropdown box' that opens. Hopefully, this gets fixed soon. 

262973_pastedImage_1.png

 

kimberly_smith1
Community Participant

A final (?) update..

Students have now been loaded into my courses and, after speaking with the Canvas Help Desk at my local institution, it appears that 'enrolled students' are able to view embedded images. Yay! So, perhaps the disappearing images from 'enrolled student' view (mentioned above) is separate from the one that engineers have been working on. If anything changes (as students begin accessing pages and assignments), I will follow-up. If you are experiencing something different, please keep us posted.

Many thanks to everyone who participated in helping bring the urgent 'diappearing images' problem to the attention of Canvas engineers (submitting problem reports and shaing case numbers with the community)! 

dsedia
Community Participant

I do not know if this is similar to the original post, but I get the hyperlink text of the image. I embedded images in a quiz and the alternative text link appeared. How does one get the entire image to display? This has been an ongoing issue, especially with the Canvas app. Is there something I am missing?

jschofield
Community Participant

Do you have all the images you are using downloaded into the course files or are you linking them to external sites?

dsedia
Community Participant

I was linking from external sites but I learned that it had to do with content filtering.