cancel
Showing results for 
Search instead for 
Did you mean: 
adickinson
Community Member

Nightly SIS upload is not working and I need to figure out why. I am a new admin for Canvas and the staff that have been involved originally are not longer at Clark Atlanta.

Nightly SIS upload is not working and I need to figure out why. I am a new admin for Canvas and the staff that have been involved originally are not longer at Clark Atlanta. 

7 Replies
kona
Community Coach
Community Coach

 @adickinson , I'm going to share this with the https://community.canvaslms.com/groups/canvas-developers?sr=search&searchId=d01a934e-f260-41b1-8c40-...‌ and https://community.canvaslms.com/groups/admins?sr=search&searchId=fcb32d0d-51d0-4982-9c72-d7ec0e0f10b...‌ groups to see if they can lend a hand; you might also consider joining these groups to get access to their information and resources. In addition, could you provide a little more information about what's going on? Are you getting any error messages? Is this synced with your Student Information System? The more information you provide the better the Community will be able to help.

scottdennis
Community Team
Community Team

Hi Adam,

Just to add to what Kona has already posted, I will alert your customer success manager that you are having difficulties with this and we'll see what we can do to help you.

abunag
Community Champion

Kona provided you with some great diagnostic questions, and Scott prodding your CSM will help too.  Whenever I'm trying to diagnose issues with the SIS feed, my first step is to check here:

https://[schoolname].instructure.com/accounts/1/sis_imports?per_page=500 

(Replacing schoolname with your own)

That page will tell you if the feed is being received by Canvas, what files it got, what changes it noted, and if there were any errors.  The timestamp for your SIS feed should match with what's on that page.

Last time we had an issue where the SIS feed wasn't actually being received, it was because our script had a bad password.  If you're using a script, is your script using the previous admin's credentials to log in?

tross
Community Champion

Or if your previous admin created the developer key, you may need to generate a new one.

garth
Community Champion

 @adickinson ‌ take a look at this resource:

The document has links to sample CSV files, which you can compare to your CSV files and determine if there is anything odd about the format of the data you are trying to import.  If something has changed in the your data this should help to flush it out.

Also, is the SIS Import reporting any errors?

Is there a specific CSV file that is failing?

If you are importing a zip file, have you tried importing the individual files one at a time to isolate the error?

Verifying your developer key is also a great idea trossSmiley Happy

KISS - attack the easy things first, if it was working it's probably something simple.

I hope you will post back your solution.

james_sanzin
Community Champion

 @adickinson ‌ What SIS are you using?

Robbie_Grant
Community Coach
Community Coach

 @adickinson ,

Were you able to find an answer to your question? I am going to go ahead and mark this question as answered because there hasn't been any more activity in a while so I assume that you have the information that you need. If you still have a question about this or if you have information that you would like to share with the community, by all means, please do come back and leave a comment.  Also, if this question has been answered by one of the previous replies, please feel free to mark that answer as correct.

 

Robbie