cancel
Showing results for 
Search instead for 
Did you mean: 
jelenab1031
Community Member

No submit button?

Jump to solution

There is no submit button on one of my assignments and I cannot continue this course until I submit this one assignment. It has been like this for about a month now on my laptop, desktop computer as well as the app. I have contacted my school and the Canvas Support team but nothing has helped. Any ideas on who to contact next or what to do?

1 Solution

Accepted Solutions
rseilham
Community Coach
Community Coach

 @jelenab1031 ​ -

This sounds like an issue with how the assignment was setup by the teacher. I would reach out to the teacher of the course have them look it. It's possible that they didn't select the correct submission type.

View solution in original post

4 Replies
rseilham
Community Coach
Community Coach

 @jelenab1031 ​ -

This sounds like an issue with how the assignment was setup by the teacher. I would reach out to the teacher of the course have them look it. It's possible that they didn't select the correct submission type.

View solution in original post

john_koon
Community Member

I just had this same problem.  Only persons listed as "students" on the Canvas course roster can make submittals in response to assignments. 

My course is conducted in a manner that students registered in another, parallel course can join teams in my course.  I entered these students as "observers" in my course roster so they could access files and receive communications.  However, I find that these students cannot make submittals for assignments that i have established in my Canvas course pages. 

Evidently, according to Canvas helpline, it is an institute decision to allow or not "observers" to make submittals to assignments.  My institution does not permit "observers" to make assignment submittals.  

Hope this helps.  

Elimbacher
Community Member

I've had multiple students report that their Submit button is missing. After reading these posts, I checked to make sure the student was part of the student group, and I checked with the teachers. All students are set up the same way, but some just don't have this option. 

I worked with the first student who reported it and determined that they were able to use this function on another computer (Chromebook in this case), so I ended up swapping out the device. Now I have 3 or 4 more students reporting the same issue. If they can do it on another device, the student and their account isn't the issue, so I'm trying to determine if it's a Browser issue or something else. 

Any other suggestions are welcome!

klundstrum
Community Coach
Community Coach

Hi @Elimbacher -- Just to clarify...the students are not in a group with a group assignment? Is the assignment included within a Module with requirements?

Are the browsers/apps updated on the other devices?