Showing results for 
Show  only  | Search instead for 
Did you mean: 
New Member

Not being able to preview documents on CANVAS

Hi, I have been suffering problems of not being able to preview documents on CANVAS since September. As a result, I have to download every document I would like to see from CANVAS, which is really unconvenient. I normally use Chrome but I also tried IE, and neither of them allow me to preview documents. Hope someone can help! Many Thanks!

8 Replies
Community Coach
Community Coach

Hi Chengyi,

What are the file types you are trying to preview and how is it "not working"?  Does the Preview Icon not even show, or does it show but continuously load the page, or display some sort of error message?  The Preview only works with Word, Excel, Powerpoint, and PDF files.  And, it's also possible for instructors to disable the inline preview of documents to force them to be downloaded.  If the files are password protected; I've also see that be an issue at times such that they must be downloaded in order to enter a password and view them in the actual application instead of using Preview.


Hi Rick,

Thanks for your reply! I was trying to preview PDF files, and the preview icons do show but it only says error message instead of displaying the full documents after I clicked on them. It worked perfectly fine last year on my laptop and when I am using computers in uni. I believe it has something to do with the certificate for my web browsers but I have no idea how to solve it.

0 Kudos

Hello there,  @cxx700 ...

Based on your e-mail address tied to your account here in the Community, it looks like you are a student.  Assuming this, it may be the case that the linked PDF file is pointing to another course.  For example, your instructor may have copied and pasted a link from a previous course into the current course you are taking, and this is why the preview is not working.  (You could easily tell this by placing your mouse over the link, and then the URL would show at the bottom of your browser.  There is a Course ID number in the URL... such as  This ID number should be the same as the Course ID number in the address bar at the top of your browser.  If it isn't, then there is a problem.)  Generally, doing something like this is not the way to create links because it is pointing to content that you do not have access to since you are, more than likely, not enrolled in that previous course.  Your instructor would want to check the course "Files" area to see if the PDF file exists there.  If it doesn't, the instructor should upload the PDF file to the "Files" area of the course and then go to the link in question within the course to correct the pathway so that it points to the current course and not a previous course.

Hope this helps a bit...

Hi Chris,


Thanks for your reply! The files I was going to preview are linked to the current courses. I did exactly the same thing last year and  worked perfectly fine on my laptop and when I am using computers in uni this year. I believe it has something to do with the certificate for my web browsers but I have no idea how to solve it.

0 Kudos

Hello  @cxx700 ...

Thanks for the reply and the additional information.  Have you tried reaching out to the folks at the Canvas Help Desk?  I think I would recommend doing this ... especially since you think it may be related to a certificate on your web browser.  You can find all the information about how to contact the Help Desk within this Guide: How do I get help with Canvas as a student?‌  I hope this will help...good luck!

That was a good shout! Many thanks for the advice!!

New Member

I've spent hours trying to find a solution and none of the existing threads have helped but I FINALLY FOUND IT

Some full access extensions on chrome that can read/write data can be culprits, for me this was Grammarly. Try disabling your extensions and adding them back one by one to find the culprit. You don't need to uninstall the extensions, just right click and set them to read and change site data only when you click the icon.

Excellent suggestion! I found this thread since I was having the same problem. Turns out the "honey" extension ( was causing the issue for me!