cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
hagedorn
Community Member

Problem using Apps in "Student View" mode

Jump to solution

I am using the Perusall App with Canvas.  I would like to test out what students see once I create the assignment in Perusall.  As an instructor, everything works well with the LTI integration.  But in "Student View",  Perusall prints the error message:

"Your LMS is configured incorrectly; the LMS is not sending the name and email address of the user to Perusall. See our support site for more information about LMS integrations."

Is this a "Student View" problem in Canvas or is there something set up incorrectly with Perusall or the App Configuration for Perusall?

Thanks!

Tom

0 Kudos
1 Solution

Accepted Solutions
nwilson7
Community Champion

@hagedorn This is an "issue" with the student view.  The test student that the student view uses is not a real Canvas account so many LTI or 3rd party integrations cannot detect the required information to allow access to their content.  Perusall requires the name and email address of the user to create an account on the Perusall side and the test student does not have those.

Hope this helps!

-Nick

View solution in original post

1 Reply
nwilson7
Community Champion

@hagedorn This is an "issue" with the student view.  The test student that the student view uses is not a real Canvas account so many LTI or 3rd party integrations cannot detect the required information to allow access to their content.  Perusall requires the name and email address of the user to create an account on the Perusall side and the test student does not have those.

Hope this helps!

-Nick

View solution in original post