cancel
Showing results for 
Search instead for 
Did you mean: 
brennem1
Community Participant

Problem with students seeing images on homepage

Hi,

I'm a newbie to Canvas and recently I created a page (in "Pages") published it and set is as my homepage (with links to some icons). My problem is that my students can click on the links but the images do not seem to show up. I went to student view and I have no problem seeing the images. I'm using Firefox (and one of the students who was having the trouble was using Chrome), so I'm not sure if this is a browser problem or what.

Thanks,

Matt

18 Replies
kona
Community Coach
Community Coach

 @brennem1 , welcome to Canvas and the Community! Here are some things to try... Have you tried viewing your course homepage in Chrome? Have you tried viewing it in student view (both in Chrome and Firefox)? Have you had your students try viewing it in Firefox? Answers to these questions can help us help you trouble-shoot this issue!

brennem1
Community Participant

Hi Kona,

I can see the page properly with student view in both Firefox and Chrome….Could it be a PC vs Mac issue?

Thanks,

Matt

kona
Community Coach
Community Coach

Ah... possibly... who is using what? Have you tried switching?

brennem1
Community Participant

First let me apologize and thank you for your response (first day of classes for me and it’s crazy)

Yes I don’t know what the students were using BUT all of them had problems and I doubt all of them had Macs (I’m using a PC), so I doubt that is the issue unless somebody says this is a common issue.

Thanks again,

Matt

kona
Community Coach
Community Coach

Honestly it could be a number of things. If it was only happening on PC (or Mac) then I'd say we were narrowing down the issue. If it was a mix then I'd go back to the browser as a possible culprit. Possibly different versions of the browser?

When you have time, can you try re-adding the images and see if that helps? Also, do you have images on any other page to see if students can see those or not?

brennem1
Community Participant

Hi Kona,

Those are all good ideas (although I doubt the outdated browser issue is a factor). I’ll play some more and report back when I’ve done some more tests/investigation.

Many thanks!!!

Matt

brennem1
Community Participant

That’s a good point (about switching). I don’t have a Mac to play with but if I can find somebody who has one, I’ll try it (plus I can ask my students next class).

Thanks!

kona
Community Coach
Community Coach

Please let us know what you find out... I'm pretty curious now as to what the issue is!

brennem1
Community Participant

So an update on this problem.

I called Canvas support. Guy was really good and checked out everything. Like myself, he said he could not detect any problem and he was working on a Mac (so we know it is not a Mac vs PC problem). The only problem he could see was that when I copied the page contents from one course’s Canvas page to another courses’ apparently I pasted multiple times. He thought the extra code could be affecting how the pics displayed.