cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
canvas_admin
Community Champion

Recent Issues in Canvas

So we just turned the new UI on for our institution this past Monday and I've had a few issues suddenly appear.  I am trying to determine if these issues are related to the new UI or are related to a recent canvas production release. Also, I'm curious if anybody else is having the same issue(s).    I've already submitted tickets for these issues and they are now at L2 level in support.  I'm asking the community more out of curiosity than anything else.

1. Discussions in SafariWhen I highlight a word in my reply window in Canvas, it immediately takes me to the bottom of the page. It’s really odd! Here’s the thing: it only happens in Safari, not Chrome.  (FIXED: corrected in Safari 9.1 release)

2. Symbol in "Print Grades":  Whenever I click the "Print Grades" button on any student's grade report and try to print to PDF (either using the native Mac PDF printer or CutePDF), a hamburger symbol (which support has told me is the menu icon) appears at the top of the PDF.  It doesn't appear on the screen before printing but appears in the print out in Chrome, Firefox, and Safari. (FIXED)

3. Discussions Row Not Scrolling: The discussion row that contains the search bar, unread button, collapse thread buttons, etc. no longer moves with the page. Now, I have to scroll all the way back up to the top to reach those functions. I've tested this in Firefox, Chrome, and Safari and it's the same in all 3! (​FIXED​)

4. Calendar Drag & Drop Not Working: Prior to switching to the new UI, I was able to drag and drop calendar events if the date changed. Now, when I try to drag and drop, nothing happens and I get a weird scrolling issue if I move the mouse to the far right of the screen. This happens in both Firefox and Safari. I did not test Chrome.  (FIXED: June 6, 2016)

5. Printing From Firefox: Printing from Firefox results in blank pages beyond the first page. Whether I'm trying to print to PDF or to a printer, pages 2+ will be blank.  It works fine from Safari, the menu icon notwithstanding. (FIXED)

Message was edited by: Mark James - Admin

13 Replies
Stefanie
Community Team
Community Team

 @canvas_admin ​, I've shared this discussion with the User Group: New UI​ in case the folks over there also saw some or all of these issues crop up at the same time they turned on the new UI.

canvas_admin
Community Champion

Update:

#1 seems to be unrelated to the new UI.  In testing in beta with the new UI OFF, the issue still occurs.  This seems to be an issue with Canvas and Safari.

#2 and #5 definitely seem to be related to the new UI.   I tested in beta with the UI on and off (everything else EXACTLY the same) and the issues appeared with the new UI on.

#3 is working in beta so hopefully this issue will go away over the weekend.

#4 is weird.  It appears that events that are listed at 11:30p will drag and drop, but not if I changed the time back to 11:59pm which are our default times when we input an event.   The time issue is discussed in the Fixed Bugs section of the most recent production notes here:   Fixed Bugs

kyrasma
Community Participant

I'm seeing somewhat similar issues and I've tested several ways.

  • First, I created an assignment and let it default to the 11:59 pm time. Note the time doesn't show in the title in Calendar:
    164685_pastedImage_14.png
    I tried to move this assignment to a different month, but it won't move.I tried to change the time to 11:50pm. It shows it changed when you mouse over, but not in the title and it will not move to a new date in the little calendar:
    164686_pastedImage_15.png
    After the attempt to move to the little calendar, the time has changed back to 11:59pm:
    164690_pastedImage_16.png
    Even if I try to change the time to 11:50pm in the course, it won't move in Calendar and the time changes back to 11:59pm in both Calendar and the course when I attempt to move it.
  • So, with the same assignment, I edited the time in Calendar to 4:15pm and it shows in the title and can be moved all day:
    164691_pastedImage_17.png  to   164692_pastedImage_18.png
  • However, I did change one other assignment at some point in all this from one time and then back to 11:59pm and it stuck - time shows in title and can be moved:
    164693_pastedImage_19.png
  • I also changed an assignment in the course that had a time of 4:50pm to 11:59pm and the time changed in Calendar = no time in title and won't move to the small calendar.
  • Also, please note that any assignment with the 11:59pm time will move within the big calendar. Just not going from the big calendar to the little calendar.
  • Finally, none of my undated items will move to the little calendar, but they will move to a date in the big calendar. The time will default to 11:59pm, no time shown in title and will not move to a date in the little calendar.

The calendar drag and drop was supposedly fixed but I had to go back to support and tell them it wasn't so it's still open right now.

It's working in beta, just not production.

canvas_admin
Community Champion

Not if you're trying to drag from the big calendar to the small calendar in the upper right corner.  I frequently have to move an event between months and drag from the big to the small often.

Hmmm, either yesterday or the day before it was because I purposely tested it and it was working.

kona
Community Coach
Community Coach

And I just tested it again and you are correct, it's not working. Smiley Sad

canvas_admin
Community Champion

So, just as an update, #3 is the only one that has been addressed and corrected as of today.

I've been told by support that #1 is a Safari issue that has been identified and will be corrected with the next update to Safari, whenever that is.