cancel
Showing results for 
Search instead for 
Did you mean: 
laurakgibbs
Community Champion

Redirect Tool error message

Jump to solution

Is anybody else getting a Redirect Tool error message this morning? This is a critical problem for me as I use the Redirect Tool to manage my class navigation. I've reported this as a Help ticket, but I don't know if it is just me, my school, or what the problem is. I am having the same error across all my Canvas sites; the redirect tool apps I have installed to add items to my navigation are not working.

redirect tool error

Tags (1)
1 Solution

Accepted Solutions
scottdennis
Community Team
Community Team

Hi laurakgibbs and carroll-ccsd and anyone else following this thread.  I wanted to let you know that I followed up with our Support folks, and then with Product and then Engineering.  The short story is that Brian did get through to the right people here who are aware of the issue and are working on an architecture level solution for edu-apps that will fix this problem for Redirect and other apps as well.  That work will get done as soon as we can in light of resource constraints and other demands on that team.  So, sorry I can't tell you it is fixed but I wanted to share that right people are aware.

View solution in original post

24 Replies
laurakgibbs
Community Champion

Canvas Support says they have not gotten any other reports of this, so here are some public pages where I am having this problem on my computer; can somebody else see if you are getting an error message. Maybe it is just me, which would be great/terrible... anyway, these pages are examples:

https://canvas.ou.edu/courses/84558/external_tools/6273
https://canvas.ou.edu/courses/86141/external_tools/7460
https://canvas.ou.edu/courses/75420/external_tools/3486
https://canvas.ou.edu/courses/54178/external_tools/2484

Hopefully it is just something weird on my computer... although that seems odd too since I have never seen an error message like this before. Hmmmm. Same error message on every page with a Redirect for me, based on what I checked. 

Hi laurakgibbs
Your links work for me. When I follow the first one, this is what I see:

293856_pastedImage_1.png
The redirect tool also works for me in my own courses so it doesn't look like a widespread problem. Have you asked your colleagues/students if the link works for them?

Oh, I am SO RELIEVED: thank you  @Steve_Watts ‌!!! This is still early for my students to be up and at it. It would be great news if this were somehow just me; I can cope until we figure it out and get it fixed. Although that sure is weird... I wonder why just me!

laurakgibbs
Community Champion

I tried clearing my cache, clearing all canvas, instructure, and edu-apps cookies, no luck.

But then I tried just pasting the launch URL into my browser and I got a clue: Chrome thinks there is a security problem here

https://www.edu-apps.org/redirect 

Is this Chrome being overvigilant, or is there really an https certificate error of some kind...?

https error

laurakgibbs
Community Champion

I'll confess to being pretty disappointed that I have not gotten a response back about this problem. It seems to be clear what is happening here from that security error message. I hope somebody at Instructure is paying attention; I decided to investigate myself since I did not hear anything more in response to my ticket and this is what I learned when I Googled this cert_symantec_legacy error:

"Error: NET::ERR_CERT_SYMANTEC_LEGACY" 

If I understand this correctly, everybody who, like me, might be using Chrome70 which went live on October 16 is possibly (?) experiencing this error with the Redirect Tool and who knows what other Instructure edu-apps that are invoking a legacy Symantec certificate for security purposes.

That is just my layperson's understanding, though, and I don't understand why I have not gotten an update in response to all this from the Helpdesk. They have Google too, right? That's what I used to find this information which appears to describe exactly the problem I am experiencing.

Very frustrating not to know how long we are going to have to wait on a fix for this.

symantec cert error

This has been announced long in advance:

Symantec Legacy PKI - The Chromium Projects 

chromium screenshot

laurakgibbs
Community Champion

Proof of Canvas awesomeness: Brian Whitmer pinged me at Twitter about how edu-apps was one of his old projects! And so he was able to confirm that this is an easy fix; it runs in-house, so hopefully early next week somebody at Instructure can fix the certificate. If I can just get this under control in time for Can*Innovate, that works for me. I really want to be able to demo my Can*Innovate course space, and it is full of Redirect Tool nav links and I use my Chromebook for video conferencing since my desktop computer is ancient and has no webcam. 

Story Lab Homepage

laurakgibbs
Community Champion

Okay, EXTREME DISSATISFACTION has now been achieved. Pinging carroll-ccsd‌ for any insight you can offer since I am by no means any kind of expert in security certificates, but here is the latest:

1. Starting on Friday morning, I became able to access any navigation links in my Canvas courses created with the Redirect Tool. I received this error message in Canvas:

The webpage at https://www.edu-apps.org/redirect might be temporarily down or it may have moved permanently to a new web address.

When I go directly to the launch URL, I get this error message:

NET::ERR_CERT_SYMANTEC_LEGACY

Screenshots of all error messages above.

2. I got no helpful information from the Helpdesk on Friday or Saturday, so on Saturday night I did my own troubleshooting and discovered that this specific Symantec legacy certificate error message is because that certificate is no longer being trusted in Chrome browsers as part of a long-announced process; the staged rollout of the certificate mistrust began on October 16. Details that I found by Googling -- all of which I shared with the Helpdesk.

https://knowledge.digicert.com/alerts/ALERT2566.html 

"Error: NET::ERR_CERT_SYMANTEC_LEGACY" 

and

https://sites.google.com/a/chromium.org/dev/Home/chromium-security/symantec-legacy-pki 

Symantec Legacy PKI - The Chromium Projects 

3. Over the weekend, I had a Twitter convo with Brian Whitmer who set up edu-apps and redirect back in the day. He agreed that it looks like a certificate that needs to be updated. I shared the details of that conversation with the Helpdesk also. I will ping Brian again at Twitter to see if he can help get through to somebody at Instructure who will listen.

4. On Monday, I heard NOTHING from the Helpdesk. I updated my case explaining that this is a serious problem that needs fixing, and if it is a certificate problem (as it surely is...???), users cannot fix the problem; only Instructure can fix the problem.

5. On Tuesday morning, the Helpdesk finally writes me back to let me know that I should adjust my privacy settings and/or disable extensions in Chrome because the problem is me.

screenshot of helpdesk message

They said they could not replicate the error, and I wrote back to explain AGAIN about the network certificate error messages and about the staged rollout, which seems to me would explain why they are not able to replicate the error. They could check on the edu-apps.org security certificate even without replicating the error... so have they checked the certificate? I don't think they have.

I am so frustrated about this. Can*Innovate is coming up on Friday, and on Monday they publicized all the presentation materials... but the course site I worked so hard to prepare in advance is going to be resulting in errors for any Chrome users who, like me, happen to be in the early stage of this staged rollout.

So, I'm sharing this information with our sysadmin and his staff so that they can pass that on to our CSM, and I'm pinging carroll-ccsd‌ and anybody else who can give me a sanity check: is there any way that a personal setting on my computer is causing this kind of error when I go to the redirect edu-apps launch page? I simply do not see how that is possible, but if somebody really thinks this is a problem on my computer, I will do some more troubleshooting. What do you think, people? I am receiving no error messages of any kind for any other website, and this error message began for me after the October date Google announced for the staged rollout of the Symantec Legacy mistrust calendar as announced back in September 2017.

https://www.edu-apps.org/redirect 

screenshot of security error message

laurakgibbs
Community Champion

See also this update from Digicert.com

https://knowledge.digicert.com/alerts/ALERT2562.html 

Reissue Certificates before Distrust Deadlines

URGENT

Description

Chrome 70 is live as of 10-16-2018.  Distrust errors may not be displayed immediately as distrust is done in stages and independent of Chrome reelease dates. Please reference the following for more information,
https://sites.google.com/a/chromium.org/dev/Home/chromium-security/symantec-legacy-pki
All SSL/TLS certificates issued from the Symantec infrastructure (before December 1, 2017) will require re-issuance to ensure continuity for your customers. This includes all brands in the Symantec family – Symantec. Thawte, GeoTrust and RapidSSL. It is strongly advised to reissue certificates as soon as possible to avoid risk or delays. Refer to our ongoing outreach for details about which certificates will be impacted, or contact your account manager now. We will replace all affected certificates at no cost to you, . Since certificates issued from the DigiCert root hierarchy are not impacted by these deadlines, you can continue to order and manage new certificates. 

robotcars
Community Champion

Putting me on the spot. :smileygrin:

I am not very proficient in security certificates. I remember it took me a few days to get our SSL certs working for our LTI, and then I was so frustrated lazy I had them duplicate the virtual machine so I could just swap the sub domains and create our test server.

From a brief glance, because I am running a short week and today is my first day in the office.

Chrome 70 is out, I write and test most of our Canvas modifications against Chrome Canary (which is currently 71).

I attempted to install the Redirect tool (again in Canary) for the nth time with no success to try and replicate. I never see it where it says it will be, and it shows no placements after 'successfully' adding the tool.

I was aware of this certificate change for the past few months, but didn't pay attention to Canvas I assumed they'd get on top of it before it became an issue... technically they still have time...

Which browsers does Canvas support? Canvas currently supports Chrome 68 and 69.

This is some of the pain of being an early adopter or allowing Automatic Updates.

The fact that they 'cannot replicate' deserves better explanation.

Can they not replicate because it's not their certificates that are causing the problem?

Did they already fix their certs?

Did they actually test in Chrome 70?

My father recently asked me to test OSX Mojave and tell him if Adobe Photoshop would still work. I updated and found that it does not, he gets to keep using Photoshop, I'm out in the cold... and I need to design the backdrop for the nursery I have to start painting in the next couple weeks.

My current suggestion would be just to try the other supported browsers and let them triage the situation as it gets more visibility. I've had to do this with Live Events not being well documented and based on my input and desire for it there is now a flood of great information provided for the community. Sometimes you're ringing the bell, sometimes you're the first in line.