Degraded AWS performance is currently impacting some Canvas users in the North American region. Check Canvas Status for updates.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AimeeESL
Community Participant

Some buttons of the screen recorder for Canvas Studio suddenly stopped functioning

Jump to solution
I have been recording with Canvas Studio. It was great! However, something changed. Now, after the screen recorder opens, I can no longer select the buttons "Webcam" and "Both" as I did previously. I click on them, but nothing happens. I'm not sure why this function stopped working; maybe because I updated my Mac OS to Big Sur…? I was thinking of uninstalling the screen recorder and reinstalling it, but I don't know how to uninstall the screen recorder from my Mac. Can anybody tell me how to do that or let me know if you have a different troubleshooting suggestion?
 
Thanks, 
 
Aimee
2 Solutions

Accepted Solutions
zsgoreczky
Instructure
Instructure

Hello All, 

This issue is indeed related to BigSur and we are working on its fix now. I apologize for all the hardships it has caused. I will update this thread once the fix it out. 

Thanks, 

Zsofi

 

View solution in original post

thasheider
Community Member

I just tried today and it worked! So I guess the Canvas engineers fixed it! 🎉🙏🏼

View solution in original post

20 Replies
scottdennis
Community Team
Community Team

Hi Aimee,

Uninstalling and reinstalling is one good idea.  Can you delete the application from your application list on your mac and try reinstalling.  Is there another computer you could test on to see if you get the same result? Do you need to re-enable a camera permission somewhere?

TammyH
Community Member

I am experiencing the same issue. The webcam and both buttons are grayed out and cannot be selected. But the screen record only works and the webcam works if you choose it from the "record" menu on the studio page. 

Running macOS Big Sur 11.0.1 on a MacBook Pro.

I also reinstalled the Screen Recorder app.

In my settings > Privacy > the Screen Recorder app has permission for camera, mic, and screen record.

I have been wondering if this issue is related to Big Sur.  Did you both possible update to Big Sur around the same time this started happening with Studio?

I updated last week and didn't need to use Studio until today. 

It is likely related to the new OS, but unfortunately, the responsibility lies with Instructure to make their stuff work with Apple... not the other way around.

Here is a video of my experience today

https://drive.google.com/file/d/17ThHcfvoFI5RESr0vNngPjezXC1LHs7y/view?usp=sharing

AimeeESL
Community Participant

Yeeesssssss! Thank you for going to the trouble to record the problem and your efforts at troubleshooting. This is exactly what I've experienced.

If the issue is indeed that Studio isn't working correctly with Big Sur, then you are absolutely correct that it is Instructure's responsibility to get things working correctly.  I'll check with our friends in Support to see if there is a known issue with this.  Thank you for the video documenting your experience.  That should be helpful in figuring out what is happening.

OK, I heard back from one additional person who is running Big Sur and using Studio and they also said those two buttons are not working.  I also checked with Support and it doesn't look like anyone has reported this in a support ticket.  Would one of you mind filing a ticket and sending me the ticket number so I can can ask to have it escalated?

Support Ticket #07018097

 

scottdennis
Community Team
Community Team

Thanks!  I'll pass this along to our support team.