cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rogers_c
Community Member

Turn off Pink Bar when Masqueraded (Act As)

Jump to solution

Ok I thought I remembered there being a trick for turning off the pink bar at the bottom when acting as a user. It blocks the Settings course navigation item. The only workaround I know about is to open a large Page that has a scrollbar which will allow you to see all of the course navigation. But if you are working in an empty shell, there may not be anything which meets this criteria.

Canvas Support says to add /settings to the URL, but that seems a bit much for something that should be so simple. 

Surely there is a better way.

1 Solution
James
Community Champion

 @rogers_c 

I thought that at one time, you could double click the purple bar to temporarily disable it on that page, but that isn't working right now. The Test Installation notice that you get within the test or beta instance works this way and so maybe I just imagined it working with the masquerade notice.

I can think of a few of ways to remove the notice.

If you have an ad blocker like uOrigin installed, you can use the eye-dropper to pick the purple banner and block it. This is permanent and gets rid of a whole bunch of other ads. However, it slows Canvas down a little (mine seems slower than everyone else anyway), so I normally leave it disabled. But if you're using it, it's an option.

A quick temporary fix if it's just on a single page is to delete the bar using the developer tools of the browser. These instructions are for Chrome.

  1. Right click on the purple bar and choose Inspect. (It's Inspect Element in Firefox).
  2. You'll see some code that looks like this. 307737_pastedImage_2.png
  3. Right click on the line that says <div id="masquerade_bar"
  4. choose Delete element

That will reappear the next time you load the page.

The other way I can think of is to modify the CSS to set the display:none; for the #masquerade_bar id. That requires a script manager like Tampermonkey or a style manager like Stylish to make it persist. There is a way with Chrome to change CSS and have it persist by using local storage, but I haven't played around with it enough to provide any advice.

View solution in original post

1 Reply
James
Community Champion

 @rogers_c 

I thought that at one time, you could double click the purple bar to temporarily disable it on that page, but that isn't working right now. The Test Installation notice that you get within the test or beta instance works this way and so maybe I just imagined it working with the masquerade notice.

I can think of a few of ways to remove the notice.

If you have an ad blocker like uOrigin installed, you can use the eye-dropper to pick the purple banner and block it. This is permanent and gets rid of a whole bunch of other ads. However, it slows Canvas down a little (mine seems slower than everyone else anyway), so I normally leave it disabled. But if you're using it, it's an option.

A quick temporary fix if it's just on a single page is to delete the bar using the developer tools of the browser. These instructions are for Chrome.

  1. Right click on the purple bar and choose Inspect. (It's Inspect Element in Firefox).
  2. You'll see some code that looks like this. 307737_pastedImage_2.png
  3. Right click on the line that says <div id="masquerade_bar"
  4. choose Delete element

That will reappear the next time you load the page.

The other way I can think of is to modify the CSS to set the display:none; for the #masquerade_bar id. That requires a script manager like Tampermonkey or a style manager like Stylish to make it persist. There is a way with Chrome to change CSS and have it persist by using local storage, but I haven't played around with it enough to provide any advice.