cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
j_avneri
Community Participant

UTF-8 import error

Jump to solution

Hi there,

Does anyone know how to reformat a CSV file so that it does not produce the 'UTF-8' format error when importing it through SIS?

Many thanks

Joe

2 Solutions

Accepted Solutions
j_avneri
Community Participant

Hi all, 

Here's how to correct this issue using notepad++ (with thanks to  @a_mcelroy ‌ for providing this!):

  1. Open notepad++ and paste in the data from the CSV that isn’t working. 
  2. Press CTRL+H and enter \t in the ‘find what’ field. 
  3. Enter a comma in the ‘replace with’ field. 
  4. Select ‘extended’ under ‘Search mode’ 
  5. Select ‘replace all’ and close then close that small window. 
  6. Select ‘file’ then ‘save as’ and type in the name of your SIS file with the CSV extension at the end e.g. ‘users.csv’ and save. 
  7. The CSV can then be imported correctly without the UTF-8 error.

regards

Joe

View solution in original post

vfuentes
Community Participant

This was so VERY helpful and worked for me. I just had to download Notepad ++ and then follow your instructions. Thanks SOOO much for posting this.

View solution in original post

0 Kudos
9 Replies
kona
Community Coach
Community Coach

 @j_avneri , greetings! I'm not sure of the answer to this question, but I'm sharing it with the Canvas Developers‌ group to see if they can help!

Kona

nr2522
Community Champion

Hello,  @j_avneri ‌.

I used to think "a CSV is a CSV", but this turns out to not be the case. I often create CSV files in Excel. I have at least four different CSV options available when saving in my version of Excel. I find that the one labelled "CSV (Comma delimited) (*.csv)" plays nice with Canvas.

Best regards,

Nelson

Excel Save As format options

robotcars
Community Champion

Should just work... I'd probably have to see the conditions of your file to determine issues.

Do you have the error Canvas returned?

user_id,login_id,password,first_name,last_name,email,status
E101,E101-DISABLED,,Test,"Tést",,active
E102,E102-DISABLED,,Tést,"W W",,active
E103,E103-DISABLED,,Tést,W Wza,,active‍‍‍‍

edit: of course Jive ate it.

315695_Screen Shot 2019-06-20 at 11.14.25 AM.png

315692_Screen Shot 2019-06-20 at 11.06.56 AM.png

315685_Screen Shot 2019-06-20 at 11.07.08 AM.png

j_avneri
Community Participant

Hi Nelson,

Thanks for your reply but unfortunately it doesn't resolve the format issue, if copying and pasting any data (data that contains the wrong formatting that causes UTF-8 error) into an excel sheet then saving it as the CSV it will still show the UTF-8 error when importing it.  

I think there is way to remove the formatting using notepad++, this strips out any extra formatting hiding in the background so that it can be imported without the error.

Many thanks

Joe 

j_avneri
Community Participant

Hi Robert,

It displays 'Invalid UTF-8' but I think there is way to remove the formatting using notepad++, this strips out any extra formatting hiding in the background so that all is left is a clean CSV and then it can be imported without the error.

Many thanks

Joe 

j_avneri
Community Participant

Hi all, 

Here's how to correct this issue using notepad++ (with thanks to  @a_mcelroy ‌ for providing this!):

  1. Open notepad++ and paste in the data from the CSV that isn’t working. 
  2. Press CTRL+H and enter \t in the ‘find what’ field. 
  3. Enter a comma in the ‘replace with’ field. 
  4. Select ‘extended’ under ‘Search mode’ 
  5. Select ‘replace all’ and close then close that small window. 
  6. Select ‘file’ then ‘save as’ and type in the name of your SIS file with the CSV extension at the end e.g. ‘users.csv’ and save. 
  7. The CSV can then be imported correctly without the UTF-8 error.

regards

Joe

View solution in original post

de_millington
Community Contributor

I found Joe's advice to work here. I had been using csv files with no issue until now. Then it finally broke with the ATF-8 error message. I checked and checked and could find nothing out of the ordinary to remedy the fault, that is until I followed the advice proffered by Joe in this space. 330 lines of text went in sweetly with only 7 further error messages about status error. Sure enough it was.

For what it's worth, I did put in a request for help through Canvas Support. The advice came back to save the CSV file as MS DOS CSV. Haven't tried it yet but that could be a quicker an even solution.

adamwarecs
Instructure
Instructure

Hi Everyone,

I came across this thread whilst looking for a client response. If you don't want to lose formatting (i.e you're updating a provisioning report from Canvas) but are unable to identify a UTF-8 character, the simplest method I've found is:

  1. Save the CSV file on your device.
  2. Import the file into Google Sheets. This automatically encodes characters for UTF-8 compliance.
  3. Download as a new CSV file and import as per the Canvas guides.

This saved me ALOT of time when importing outcomes.

Enjoy! 😎

vfuentes
Community Participant

This was so VERY helpful and worked for me. I just had to download Notepad ++ and then follow your instructions. Thanks SOOO much for posting this.

View solution in original post

0 Kudos