cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sfrances
Community Participant

Unable to view TurnItIn reports through Canvas/Crocodoc

Jump to solution

I have students submit their essays to TurnItIn through the Canvas interface, and then I grade/comment via Crocodoc Speedgrader.  On the Crocodoc page, there's a button that displays the TurnItIn similarity score (see screenshot below for reference--it's the orange square), and I should be able to click this to access the full report.  However, my button just takes me back to the course homepage and gives me an error message that says, "Couldn't find valid settings for this link."  

Has anyone else experienced this problem?  Any idea if this is a support ticket for Canvas, for TurnItIn, or for my own IT support team?

Thanks, Sherrin

217792_pastedImage_3.png

1 Solution

Accepted Solutions
dhulsey
Community Champion

Hi,  @sfrances . The problem you are having is a result of an incorrect. LTI set up for Turnitin. If you are the one configuring the app, you can fix this yourself; otherwise, contact your local Canvas administrator.

The problem is that the domain field in the app has been left blank. It should be filled in with "turnitin.com"

You can refer to my blog here in the Canvas community for images and an explanation of how the LTI app should be configured: https://community.canvaslms.com/groups/plagiarism/blog/2015/04/18/canvas-and-turnitin?sr=search&sear...‌.

Let me know if that helps!

View solution in original post

7 Replies
chofer
Community Coach
Community Coach

 @sfrances ‌...

I'm assuming that your school has the Turnitin LTI configured for your Canvas instance and that you've set up your assignment similar to what  @clong ‌ has outlined in his video: Turnitin LTI App in Canvas LMS - For Teachers - YouTube (look at around the 3 minute 50 second mark).  Later on in the video, he talks about how to view student submissions via the Turnitin LTI interface vs. using the SpeedGrader.  Give this a try to see if will work for you.

sfrances
Community Participant

Thank you for the reply.  Yes, I create my assignments just as described in the video.  The buttons on the Assignments page and within the gradebook itself do work (see below for screenshots of the pages I mean).  But the button within Crocodoc is broken, and this is how I choose to do my grading so it's annoying. 

217793_pastedImage_2.png

217794_pastedImage_3.png

217795_pastedImage_4.png

Hi  @sfrances ‌...

Hmmm...I did some testing myself in my sandbox course with a dummy student user.  After submitting a one-page document that I wrote myself, I submitted it to the Turnitin-enabled assignment in my course.  After I could see the percentage, I tried clicking on it in both the Grades and the SpeedGrader view that you showed above.  The FeedbackStudio interface of Turnitin opened right up for me...no issues.  So, I'm not exactly sure why you would be having issues.  I'm going to tag  @dhulsey ‌ in this message to see if he might have any thoughts for you...he's the "go to" guy for Turnitin here in the Community.  Smiley Happy

dhulsey
Community Champion

Hi,  @sfrances . The problem you are having is a result of an incorrect. LTI set up for Turnitin. If you are the one configuring the app, you can fix this yourself; otherwise, contact your local Canvas administrator.

The problem is that the domain field in the app has been left blank. It should be filled in with "turnitin.com"

You can refer to my blog here in the Canvas community for images and an explanation of how the LTI app should be configured: https://community.canvaslms.com/groups/plagiarism/blog/2015/04/18/canvas-and-turnitin?sr=search&sear...‌.

Let me know if that helps!

View solution in original post

sfrances
Community Participant

Chris and Dallas, thank you both so much!  I am not the one configuring the app, but I do know who that is on my campus.  I will contact him this week with the information you have provided.  Thanks again!

sfrances
Community Participant

Quick update--the IT team here made a fix based on your advice, and now all the buttons work.  Thank you!

dhulsey
Community Champion

Excellent! I am glad we could help. Smiley Happy