cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sharked
Community Participant

Why did upload of webcam video only show green screen throughout?

I just did a 16+ minute video using the webcam to document a detailed diagram drawn on a whiteboard.  It took a long time to upload and then I discovered there was no visual, only audio, the visual is nothing but a green screen throughout.  Why did this happen and is there anything I can to do to retrieve the visual part?

7 Replies
scottdennis
Community Team
Community Team

Hi Debra,

How long has it been since you uploaded the video and is it still not showing the imagery?  I'm wondering if it took some time to process after you uploaded it.

sharked
Community Participant

Overnight.  A student reported it this morning.  I noticed the upload taking longer than normal and when it finally came through it had a green screen for a thumbnail.  I changed the thumb nail to a screenshot but didn't test the video until this morning after a student reported the problem.  Is there any way to retrieve the "video" part of this recording or do I need to redo it?

Hi Debra,

Unfortunately my best advice is that you redo the work you did.  Not just with regards to Canvas but I have heard a lot of reports lately of people experiencing delays and failures with regards to moving large files across the Internet.  Because of that I would advise that you first record the video onto your hard drive and then upload it to the Canvas rich content editor so that if another failure occurs you will still have the original file to work with.  I am sorry I don't have better news to share.

sharked
Community Participant

Unfortunately, I cannot record the video onto my hard drive from "Studio" within Canvas.  It only will allow me to upload the video to "Studio."  As workaround I see two other options, using Camtasia 19 (which I own but don't have much experience using) or the Screencast-o-Matic website which has a 15-minute cap on recordings.  The latter doesn't help much with making a video diagramming a process that takes longer than 15 minutes to explain adequately.  I just tested Studio again using the back-and-forth between webcam and screencam and it's working but taking a long time to upload (a 10-second test video).  I think you're correct that the problem here may be bandwidth on somebody's server given huge increase in online video processing post-COVID 19.  Thanks.  Back to the drawing board I reluctantly go...

sharked
Community Participant

P.S.  I was hoping someone from Canvas would tell me the "video" part of my upload was stored somewhere on Canvas' server (i.e. a file that could be retrieved on Canvas' end.)  Oh well...

Again, sorry to hear that you are in this bind.  For what its worth, years ago, I used Camtasia to create recordings that I then uploaded to the Canvas rich content editor Insert/edit media tool.

342237_Screenshot 2020-03-21 14.19.16.png

Sara-Newman
Community Member

I have a savvy instructor who ran into this trouble (added a video that when played back had a green screen - audio was there but video was greenish).

None of our eLearning staff could replicate this teacher's experience on our Mac's, PC's and varied browsers. So I assumed this was specific to this teacher's computer and browser settings because these videos are working for her students and our staff on our varied setups.

Upon working with the teacher virtually today (12/30/2020) we narrowed the trouble down to her PC, her Chrome browser and her videos (whether they were youtube or self-created did't matter) placed on an assignment page is when they would turn green upon play. When placed on a regular Canvas page, she didn't get the green screen. I stripped down the video code to its bare minimum on the assignment page in case. 

The same videos placed on a regular Canvas page (not an assignment page) didn't turn green for her. We tested her assignment page and regular page in Firefox and had no trouble with any of the videos we tried on both assignment pages and regular Canvas pages. Which means this troubleshooting is pointing us to something to do with her Chrome/PC's experience/settings and whatever assignment page code personal PC is complaining about.

Bottomline:

  1. More work is needed on determining what Chrome, on her personal PC, is running into on videos embedded/linked on assignment pages that its balking at.
  2. The students and our eLearning staff are not experiencing trouble with these videos.
  3. The teacher is now using Firefox to view her assignment pages where she's embedded videos.