cancel
Showing results for 
Search instead for 
Did you mean: 
clare_smith
Community Participant

YouTube LTI failing!

Hi - Has anyone else had this issue, and if so did you resolve? No matter what I search for when using the youtube external tool, 0 results are returned.

Canvas support suggested re-installing the LTI but I don't want any existing links to be broken. I tried this in the Test environment but it remains the same. It is not security/proxy related, as I've tested externally too.

I have asked Canvas support to elevate, though I was told that this LTI is something they don't necessarily support. If they respond with a solution I'll post here too. 

In the meantime - any ideas? 

thanks.

Clare

YouTube LTI failure

Tags (2)
5 Replies
Robbie_Grant
Community Coach
Community Coach

 @clare_smith ,

I have tested the YouTube LTI in our instance and am seeing the same result.  I have also opened a ticket with Instructure Support.  Can you please provide me with your ticket number as well?

Thank you,


Robbie 

Hey  @Robbie_Grant  and Deactivated user

My case number is 01985035 

Thanks, hopefully it can be sorted Smiley Happy 

jlange1
Community Member

I am still having this problem quite frequently - even when I have the exact name of the video and the author.  Searching by url also doesn't work.  For instance, today I was trying to embed Shotgun Histology Lung - YouTube , but the LTI couldn't find that specific video.

Smiley Sad

I have this issue as well. In chatting with a Canvas support person, it sounded like there wasn't actually a 'search by URL' feature, but I'm sure that we used to be able to do that. I've also noted that the same search terms that get results in Youtube or Vimeo website do not get any results within the LTI. Is this issue still affecting you?

chofer
Community Coach
Community Coach

Hello there,  @clare_smith ,  @jlange1 , and  @andrea_mclagan ...

I have been reviewing older questions here in the Canvas Community, and I stumbled upon this question.  In doing my own testing of the YouTube LTI in my sandbox course, it appears that I can successfully search for videos.  I did see the "0 results" message for about one second the first time I searched for a video, but then that message went away and video search results showed up...giving me what I was looking for.  Are any of you still experiencing this issue on your end?  Has it been resolved for you?  If it is still giving you "0 results", I would recommend that you update your support ticket (or submit a new ticket if you haven't done so already)...as  @Robbie_Grant  had suggested back in April 2017.

Another option for you (which I happen to like better) is harvesting the embed code directly from YouTube's website.  The YouTube LTI always seems to put some black bars above and below the video.  Compare this with embed code you get from YouTube's website, and you won't see those black bars...giving your students a nicer display of the video.

Since this appears to be working (at least for me), I am going to mark this question as "Assumed Answered".  However, if you feel that my response (or any of the above responses) has helped to answer your question, please click the "Mark Correct" button next to that response.  Marking your question as "Assumed Answered" will not prevent you or others from posting additional questions and/or comments below that are related to this topic.  I hope that's alright with you, Clare.  Looking forward to hearing back from one (or all) of you soon!