Single Thread Logout

Jump to solution
Community Champion

Edit: I have confirmed that this does not occur only for me. A co-worker went through the same troubleshooting I did with identical results. To ensure it isn't just something being caused by our network, I further attempted to access from my home desktop (through a RDC) with no change in the symptoms. Something about that thread is not recognizing us as being logged in.


The name kind of says it all. There is a single thread (Icons for items in Syllabus Table | Canvas Community ) that shows me as being logged out regardless of my browser/computer and how I access it.

What I've tried:

  1. Cleared cache and cookies, restarting browser
  2. Tried alternate browsers (IE11, Chrome 51, and Firefox 46)
  3. Accessing the thread directly (pasting the URL directly into the browser), then selecting the Login link at the top
    • This redirects me for the community homepage after logging in
  4. Accessing the thread via a link in another thread
  5. Accessing the thread via the list of threads

All attempts resulted in my being logged in anywhere else, but that one thread would not recognize it, and this happened on two different computers. The most annoying thing is that I don't have to re-login when this happens. I can just go to another page is it recognizes I'm logged in. It's, so far, just this one thread causing trouble (a thread I'm trying to post to for spreading word of two ideas I've posted).

Am I doing something wrong?

1 Solution

I believe I figured out what the problem is. The links provided by  @kmeeusen  ​and  @biray  both go to​ When signing into this domain, users are redirected to So, assuming login validation is by the domain name, which is what it looks like, then this makes perfect sense.

However, what strikes me as odd about this is that I had tested this issue by going through the thread list. Checking my browsing history, the only page that comes up for the domain is that thread, indicating that I was on the correct domain when I was testing this out.

My best guess is that I ended up with some odd caching issue. After my system had been rebooted, I was able to access the correct domain for the thread and make the intended post.

There's still several unanswered questions, specifically regarding the domain confliction. Everything I do to login in automatically redirects me to the domain, so I'm not sure how the links could've been incorrect when a user already signed in went to access them.

View solution in original post