Showing results for 
Search instead for 
Did you mean: 
Community Member

USU Design Tools/Kennethware Configuration Problem? - TrivialOAuthDataStore.php error

Jump to solution

I configured the template wizard and when I clicked the link to it, the authorization screen displayed. I was able to log in just fine.  However, I'm seeing the errors shown near the top of the image below.  I understand that this may be a configuration issue, but I have double-checked everything and can't seem to find what is causing the problem.  Has anyone else experienced this problem.  FYI, I was able to use the wizard to create a front page without any problem.

If you have any suggestions​, I would greatly appreciate any help you can provide.

- Elena


14 Replies

That will be great, I work on a server supplied by our IT department that has been around longer than I have, so I am not sure what customizations have been made to it over the years.


Hello​ &

I have run into a similar issue.  Our Kennethware 2.0 deployment is on a Windows 2008 R2 server with Apache 2.4.  I've enabled cURL in the PHP.ini file by adding the line:


; A default value for the CURLOPT_CAINFO option. This is required to be an

; absolute path.

curl.cainfo = "cacert.pem"

However, I'm still receiving the following error:

Screen Shot 2016-04-12 at 10.56.34 AM.png

I've updated the files TrivialOAuthDataStore.php and oauth2response.php listed in the errors reported at further up in this thread.( & TrivialOAuthDataStore.php Function Declaration Errors · Issue #29 · CIDI/kennethware-2.0 · GitHub​)

Any help with resolving the errors found in lines 62 and 79 for the file /resources/wizard_pages.php would be tremendously appreciated!

Thanks in advance,


Hey Jason,

The CURL fix ( ) says that the full path must be provided for the certificates:

"If you’re running PHP version 5.3.7 or later you can edit your PHP.INI file to include: curl.cainfo = “PATH_TO/cacert.pem”   Where PATH_TO is your actual path (c:/windows for example)"




That was a simple fix!  I followed your input and changed the curl.cainfo = “C:/PATH_TO/cacert.pem” and it worked perfectly. 

Thank you so much, I really appreciate your assistance!!!



You are all great! Thank you so much for all of your help. My server knowledge is extremely limited since our IT department handles all of that and I have just developed based on what I had access to. I means a lot to me that you are willing to chime in with your expertise and experience.