cancel
Showing results for 
Search instead for 
Did you mean: 

New Quiz Export Doesn’t Work As You Would Expect (It’s Broken)

New Quiz Export Doesn’t Work As You Would Expect (It’s Broken)

0 Kudos

As title says, when you export a course with New Quizzes, it doesn’t really export the New Quizzes.  Here are the steps to confirm this:

(1)  Create a new course, add a New Quiz, and create some questions directly in the New Quiz.

(2) Export this course directly to another new course or do it by creating an export package and then import it to another new course.

(3)  At this point, the New Quiz in that export will copy correctly onto the 2nd new course.

(4)  Now, reset both courses you just made using “Reset course content” button.

(5) Then use the export package to reimport that course with the New Quiz and you’ll see that the New Quiz will not make a copy.  All settings on that quiz and questions inside will disappear.

 

Please edit this behavior.  It’ll cause a lot of problems for a lot of users as well as for the support team.

Tags (2)
5 Comments
Stefanie
Community Team
Community Team
Status changed to: Moderating

@HienDN After you reset the courses, did you re-enable New Quizzes in the course settings for the destination course before initiating the import of the previously created export package?

HienDN
Surveyor

Yes.  Also a tech from Canvas Support duplicated this problem as well.  I didn't see this posted as a known issue so I posted it.

Stefanie
Community Team
Community Team

@HienDN 

Thanks. We have a conversation underway requesting changes to the New Quiz export/import process. Would you add the results of your investigation to the comments section of a related discussion underway at  Export/Import New Quizzes/Question Banks? Having the thread unified will assist our members to assess problem statements and use cases and our product manager in coming up with a solution.

Stefanie
Community Team
Community Team
Status changed to: Archived
 
HienDN
Surveyor

Just did.  I was on that forum before searching for similar issues I experienced.  People ran into this problem before, but they think the issue is it won't export to a different account.  The real issue is actually it won't even export at all.