Assignment submission error

Jump to solution
Community Novice


I have a student that is unable to submit any assignments in any format on an iPad.  For example, she was trying to submit an essay created in Google Docs.  When she hits Turn in and then selects the file, she hits the submit button and then receives an error message that the submission failed (CKCanvasErrorDomain error 401).  I tried to submit it as a Word document, a PDF, a URL, even tried to submit it as a snapshot (but Canvas wasn't even a sharing option).  Does anyone have any idea how to get around this, other than having her go to a computer to submit her work.  Our school is 1:1 iPads this year and submitting assignments has been a constant issue.  Thanks for any suggestions.

5 Solutions
Community Champion

Hi Brandon,

Have you tried deleting the Canvas app on the iPad then reinstalling it? Sometimes there are caching errors that can occur and a complete delete and reinstall magically fixes everything. That being said, if this does not help, your next course of action should be to report the problem to the Canvas support team. When you are in the app trying to submit the assignment go to the help menu and select "report a problem". Doing this will capture information about the device and place this in an official help case file. From there you should hear back from someone at your institution or Canvas (depending on how your support is set up).

Let us know how this goes Smiley Happy

View solution in original post

Community Contributor

Another try is to log in through a web browser and not the app.  Several of my students have had the same issue with viewing my assignments, and viewing them through a browser fixed the problem. 

Please let me know if you find a solution.  A portion of  my school's students will be going to 1:1 with iPads next school year.   

View solution in original post

Ok, I uninstalled the app then reinstalled it.  Still had the same issue.  Her teacher sent her down to the library to submit through the web browser.  I'll keep trying to figure this out.  I didn't report it through the app yet.  Thanks for your suggestion though.

View solution in original post

Community Explorer

I'm having this problem, too.  My student is trying to submit a GarageBand file using a laptop, something she has done several times for the class so far.  Other students have submitted files; it's only this one student that seems to be having this problem. I have had her restart and try again, to no avail.  Whazzup?

View solution in original post


With GarageBand at our school, we suggest that student export the file from GarageBand to Google Drive and then share/submit the link into the Canvas Student app.

View solution in original post