cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sarah_dille
Community Member

Outcomes not working

I've imported outcomes from my institution into my course, but they do not show when I try to attach a quiz question to the outcome. 

Tags (1)
10 Replies
jsparks
Instructure
Instructure

Has this been resolved?  There is a delay in the sync.

tom_gibbons
Community Contributor

I'm seeing this as a problem, too. Single-item outcomes alignment is one of the more interesting features of the new quizzing platform, for my institution. I built some outcomes into a course, and it's not working. 

I note the language in the interface: "Align Institution outcomes..." Does this imply that only outcomes set at the institutional level, rather than the course level, can be aligned? I'm guessing that's not the case, since I can't see institution-level outcomes either. 

The documentation indicates that outcomes might not be enabled for my course, and so I should check with the institutional admin. I'm one of the institutional admins. I'm not seeing any config options for outcomes at the course level. Unless this is tied to the functionality in the Learning Mastery Gradebook, somehow? I'm not seeing that LMG activation makes a difference, though. 

So, any known issues? 

leward
Community Contributor

Can you clarify what type(s) of outcomes are supported.  The prompt mentions Institution outcomes.  Does this mean only outcomes in the root level account will be available in LTI Quizzes?  Or should we expect outcomes in any parent node to display?  I've got outcomes defined in parent nodes as well as in the course.  It's been more than five days since I created a test quiz and no outcomes are showing as available for alignment.

rake_9
Community Champion

I personally, have not tested this, but I would be interested in clarification.  I noticed the reference to "institutional outcomes" and thought it was odd.  My assumption is that all outcomes (regardless of where they are created) could be attached. 

MattHanes
Community Champion

We just joined the Beta and we're having the same issue. Outcomes aren't showing up in the LTI. Is this still a problem for everyone else?

MattHanes
Community Champion

Nevermind, I made the most classic mistake. I didn't have the outcomes actually imported into the sub-account that I put my test course in.

craigring
Community Participant

Hi there,

We initially had the same issue as others have mentioned here. However, Canvas Support notified us that there was a delay in the sync. After a bit of playing around they were soon available. 

Attaching outcomes to individual questions is an awesome feature! Below you can see the report that is generated within the LTI that highlights areas of strength and weakness from students taking a quiz:

Outcomes Report

Not only can we see an individual student's progress, we can also see where we may need to focus our planning as teachers:

Outcome detail

The major problem we have now is that the Outcome results are not syncing back with the Learning Mastery Gradebook, which means we can't see the overall data from multiple quizzes and outcomes linked to the Outcomes. Students also can't see their individual analysis (unless I haven't found that option yet). 

saif
Community Member

We are having the same issues with the outcomes:

  1. When updating an outcome, there seems to be a delay in syncing that updated outcomes to the LTI (the outcomes don't appear in the assignment page).
  2. When questions are aligned to the outcomes, the Mastery Gradebook does not update (the Student View shows 0 Alignments on the outcomes, which is not the case).
  3. The Formula functionality does not insert the formulas correctly until you press the done button.
  4. Item Banks not working: If one user creates an Item Bank, other users can't see it. So we can't add items to banks in the Quizzes.next
  5. Unable to duplicate or export any Quizzes.next assignments (this is coming in a future release I believe)

We had an update from the Canvas team that these will be sorted within a month or so. So hopefully this will resolve everyone's issues. 

When you say "playing around" what do you mean?